summaryrefslogtreecommitdiffstats
path: root/testing/xmlrpc-c
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-25 14:38:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-25 14:38:16 +0000
commit8a19e364da407268b0338e1c76d92cfbd422b0c7 (patch)
tree1ba79d31af98753ec3fb8e774aaee4ef87175633 /testing/xmlrpc-c
parente14dd28447d272027ebd9bf045eb0a6bd428f0c2 (diff)
downloadaports-8a19e364da407268b0338e1c76d92cfbd422b0c7.tar.bz2
aports-8a19e364da407268b0338e1c76d92cfbd422b0c7.tar.xz
testing/xmlrpc-c: new aport
This library provides a modular implementation of XML-RPC for C and C++ http://xmlrpc-c.sourceforge.net/
Diffstat (limited to 'testing/xmlrpc-c')
-rw-r--r--testing/xmlrpc-c/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/xmlrpc-c/APKBUILD b/testing/xmlrpc-c/APKBUILD
new file mode 100644
index 000000000..86777e1b6
--- /dev/null
+++ b/testing/xmlrpc-c/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xmlrpc-c
+pkgver=1.06.40
+pkgrel=0
+pkgdesc="This library provides a modular implementation of XML-RPC for C and C++"
+url="http://xmlrpc-c.sourceforge.net/"
+license="custom:xmlrpc-c"
+depends=
+makedepends="libtool curl-dev libxml2-dev zlib-dev"
+subpackages="$pkgname-dev $pkgname-doc xmlrpc-c++:cxx"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-libxml2-backend \
+ --disable-cgi-server \
+ --disable-abyss-server \
+ --disable-libwww-client \
+ --disable-wininet-client
+ # no parallel builds :-(
+ make -C include &&\
+ make -C lib &&\
+ make -j1 -C src &&\
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -m 644 -D doc/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+cxx() {
+ pkgdesc="This library provides a modular implementation of XML-RPC for C++"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*++* "$subpkgdir"/usr/lib/
+}
+
+md5sums="684fd8b9edda6da55a58d2a18e5056c5 xmlrpc-c-1.06.40.tgz"