summaryrefslogtreecommitdiffstats
path: root/testing/yaml
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-31 17:53:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-31 17:53:37 +0000
commitb8ebe7fe4fc69c45072580f7f2d367f12f427e4d (patch)
tree96e04c45aeeb6e08356b4ea1596413ce42f523e8 /testing/yaml
parent1089ac1333dd4b02b53b52dd62db5ed300b23239 (diff)
downloadaports-b8ebe7fe4fc69c45072580f7f2d367f12f427e4d.tar.bz2
aports-b8ebe7fe4fc69c45072580f7f2d367f12f427e4d.tar.xz
testing/yaml: new aport
YAML 1.1 parser and emitter written in C http://pyyaml.org/wiki/LibYAML
Diffstat (limited to 'testing/yaml')
-rw-r--r--testing/yaml/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/yaml/APKBUILD b/testing/yaml/APKBUILD
new file mode 100644
index 000000000..f93c31ccf
--- /dev/null
+++ b/testing/yaml/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=yaml
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="YAML 1.1 parser and emitter written in C"
+url="http://pyyaml.org/wiki/LibYAML"
+arch="all"
+license="MIT"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz"
+
+_builddir="$srcdir"/yaml-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="36c852831d02cf90508c29852361d01b yaml-0.1.4.tar.gz"