summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2010-12-16 10:15:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 12:29:45 +0000
commit027fc6a04c9ad2b7026f2c0e4821dbd74ee944a0 (patch)
treedcd74903aac8990635a15459d7bd77a532a62be3 /testing
parentd0e4cf03b9f91c15605ce87809251f725f266c2c (diff)
downloadaports-027fc6a04c9ad2b7026f2c0e4821dbd74ee944a0.tar.bz2
aports-027fc6a04c9ad2b7026f2c0e4821dbd74ee944a0.tar.xz
testing/libcue: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/libcue/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/libcue/APKBUILD b/testing/libcue/APKBUILD
new file mode 100644
index 000000000..3c61236a2
--- /dev/null
+++ b/testing/libcue/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=libcue
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="library for parsing cue files"
+url="http://libcue.sourceforge.net/"
+license="GPL"
+arch="all"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="5f5045f00e6ac92d9a057fe5b0982c69 libcue-1.4.0.tar.bz2"