summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-17 19:24:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-17 19:24:34 +0000
commit06d15e91368ce388da9b0191547bb62ea5e712d2 (patch)
tree5664fdfd554f167748a32a5b7c5328648e823844 /testing
parent2710ef4b124a558802611e95cbb9513d0a4075dc (diff)
downloadaports-06d15e91368ce388da9b0191547bb62ea5e712d2.tar.bz2
aports-06d15e91368ce388da9b0191547bb62ea5e712d2.tar.xz
testing/libdaemon: new aport
A lightweight C library which eases the writing of UNIX daemons http://0pointer.de/lennart/projects/libdaemon/
Diffstat (limited to 'testing')
-rw-r--r--testing/libdaemon/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/libdaemon/APKBUILD b/testing/libdaemon/APKBUILD
new file mode 100644
index 000000000..7a39c98df
--- /dev/null
+++ b/testing/libdaemon/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libdaemon
+pkgver=0.14
+pkgrel=0
+pkgdesc="A lightweight C library which eases the writing of UNIX daemons"
+url="http://0pointer.de/lennart/projects/libdaemon/"
+arch="all"
+license="LGPL"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://0pointer.de/lennart/projects/libdaemon/libdaemon-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build () {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --disable-lynx \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="509dc27107c21bcd9fbf2f95f5669563 libdaemon-0.14.tar.gz"