summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2010-12-19 15:16:35 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2010-12-19 15:16:35 +0000
commit64d0ff18cae6e15062baabb62c565da326d6e566 (patch)
tree7a7ebe766447647ddeae429a1c83d1894785c00b /testing
parent20bfb54fb4ffbd34deedd2722a0d310e7f96cf2f (diff)
parent24c6d1edf1b52d72a48d013826650c9dd13b6492 (diff)
downloadaports-64d0ff18cae6e15062baabb62c565da326d6e566.tar.bz2
aports-64d0ff18cae6e15062baabb62c565da326d6e566.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
Diffstat (limited to 'testing')
-rw-r--r--testing/avahi/APKBUILD113
-rw-r--r--testing/avahi/avahi.pre-install13
-rw-r--r--testing/avahi/gnome-nettool.pngbin0 -> 4509 bytes
-rw-r--r--testing/bluez/APKBUILD20
-rw-r--r--testing/bluez/bluetooth.initd2
-rw-r--r--testing/gnome-bluetooth/APKBUILD4
-rw-r--r--testing/gnome-disk-utility/APKBUILD60
-rw-r--r--testing/gnome-disk-utility/exp2.patch16
-rw-r--r--testing/gnome-disk-utility/fix-freeze.patch32
-rw-r--r--testing/gvfs/APKBUILD72
-rw-r--r--testing/gvfs/gvfs.trigger6
-rw-r--r--testing/libarchive/APKBUILD33
-rw-r--r--testing/libdaemon/APKBUILD29
-rw-r--r--testing/lua-sec/APKBUILD40
-rw-r--r--testing/obex-data-server/APKBUILD29
-rw-r--r--testing/obexd/APKBUILD28
-rw-r--r--testing/openobex/APKBUILD5
-rw-r--r--testing/psmisc/APKBUILD36
-rw-r--r--testing/xz/APKBUILD37
19 files changed, 541 insertions, 34 deletions
diff --git a/testing/avahi/APKBUILD b/testing/avahi/APKBUILD
new file mode 100644
index 000000000..1a324acc9
--- /dev/null
+++ b/testing/avahi/APKBUILD
@@ -0,0 +1,113 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=avahi
+pkgver=0.6.28
+pkgrel=2
+pkgdesc="A multicast/unicast DNS-SD framework"
+url="http://www.avahi.org/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="gtk+-dev gdbm-dev"
+makedepends="py-gtk-dev py-dbus-dev intltool gobject-introspection expat-dev
+ libdaemon-dev glib-dev dbus-dev libcap-dev gdbm-dev gtk+-dev py-gdbm"
+install="$pkgname.pre-install"
+pkgusers="avahi"
+pkggroups="avahi"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools $pkgname-ui-tools:uitools
+ $pkgname-glib $pkgname-ui $pkgname-libs $pkgname-compat-howl:howl
+ $pkgname-comat-libdns_sd:lidns_sd"
+source="http://www.avahi.org/download/avahi-$pkgver.tar.gz
+ gnome-nettool.png"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ # we dont build autoipd since dhcpcd does same job
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-autoipd \
+ --disable-qt3 \
+ --disable-qt4 \
+ --disable-gtk3 \
+ --disable-mono \
+ --disable-monodoc \
+ --disable-doxygen-doc \
+ --disable-xmltoman \
+ --enable-compat-libdns_sd \
+ --enable-compat-howl \
+ --with-distro="gentoo" \
+ --with-systemdsystemunitdir=/lib/systemd/system
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -d -o avahi -g avahi "$pkgdir"/var/run/avahi-daemon
+ ln -s avahi-compat-howl.pc "$pkgdir"/usr/lib/pkgconfig/howl.pc
+ ln -s avahi-compat-libdns_sd.pc \
+ "$pkgdir"/usr/lib/pkgconfig/libdns_sd.pc
+ ln -s avahi-compat-libdns_sd/dns_sd.h "$pkgdir"/usr/include/
+}
+
+tools() {
+ pkgdesc="Command line tools for mDNS browsing and publishing"
+ mkdir -p "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/bin
+ mv avahi-browse* avahi-publish* avahi-resolve* avahi-set* \
+ "$subpkgdir"/usr/bin/
+}
+
+uitools() {
+ pkgdesc="UI tools for mDNS browsing"
+ depends="py-gtk py-dbus py-gdbm"
+ mkdir -p "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/bin
+ mv avahi-bookmarks avahi-discover avahi-discover-standalone b* \
+ "$subpkgdir"/usr/bin/
+ install -D -m 644 "$srcdir"/gnome-nettool.png \
+ "$subpkgdir"/usr/share/pixmaps/gnome-nettool.png
+}
+
+glib() {
+ pkgdesc="Glib libraries and GObject wrapper for avahi"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libavahi-glib.so.* \
+ "$pkgdir"/usr/lib/libavahi-gobject.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+ui() {
+ pkgdesc="Gtk user interface library for Avahi"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libavahi-ui.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+libs() {
+ pkgdesc="Libraries for avahi run-time use"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libavahi-common.so.* \
+ "$pkgdir"/usr/lib/libavahi-client.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+
+howl() {
+ pkgdesc="Libraries for howl compatibility"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libhowl.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+lidns_sd() {
+ pkgdesc="Libraries for Apple Bonjour mDNSResponder compatibility"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libdns_sd.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+md5sums="d0143a5aa3265019072e53ab497818d0 avahi-0.6.28.tar.gz
+42c2905307c7a5dc6ac4b75f4c3d65a3 gnome-nettool.png"
diff --git a/testing/avahi/avahi.pre-install b/testing/avahi/avahi.pre-install
new file mode 100644
index 000000000..e982c7d41
--- /dev/null
+++ b/testing/avahi/avahi.pre-install
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+addgroup -S -g 28 netdev 2>/dev/null
+addgroup -S -g 86 avahi 2>/dev/null
+adduser -u 86 \
+ -h /var/run/avahi-daemon \
+ -s /bin/false \
+ -S -D -H \
+ -g "Avahi System User" \
+ -G avahi \
+ avahi 2>/dev/null
+
+exit 0
diff --git a/testing/avahi/gnome-nettool.png b/testing/avahi/gnome-nettool.png
new file mode 100644
index 000000000..227d0678a
--- /dev/null
+++ b/testing/avahi/gnome-nettool.png
Binary files differ
diff --git a/testing/bluez/APKBUILD b/testing/bluez/APKBUILD
index 70aa179df..746762d20 100644
--- a/testing/bluez/APKBUILD
+++ b/testing/bluez/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
-pkgver=4.72
+pkgver=4.81
pkgrel=0
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
@@ -10,7 +10,7 @@ depends=
makedepends="dbus-dev gst-plugins-base-dev alsa-lib-dev libusb-compat-dev
libnl-dev"
subpackages="$pkgname-dev $pkgname-doc libbluetooth $pkgname-alsa $pkgname-cups
- $pkgname-netlink $pkgname-gstreamer"
+ $pkgname-gstreamer"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
bluetooth.initd
bluetooth.confd
@@ -27,7 +27,6 @@ build() {
--enable-gstreamer \
--enable-alsa \
--enable-usb \
- --enable-netlink \
--enable-tools \
--enable-bccmd \
--enable-hid2hci \
@@ -57,8 +56,8 @@ libbluetooth() {
alsa() {
pkgdesc="Bluez plugin for ALSA"
- mkdir -p "$subpkgdir"/etc "$subpkgdir"/usr/lib
- mv "$pkgdir"/etc/alsa* "$subpkgdir"/etc/
+ mkdir -p "$subpkgdir"/usr/share "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/share/alsa* "$subpkgdir"/usr/share/ || return 1
mv "$pkgdir"/usr/lib/alsa* "$subpkgdir"/usr/lib/
}
@@ -68,19 +67,12 @@ cups() {
mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
}
-netlink() {
- pkgdesc="Bluez netlink plugin"
- mkdir -p "$subpkgdir"/usr/lib/bluetooth/plugins
- mv "$pkgdir"/usr/lib/bluetooth/plugins/netlink.so \
- "$subpkgdir"/usr/lib/bluetooth/plugins
-}
-
gstreamer() {
pkgdesc="Bluez plugin for gstreamer"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/gstreamer* \
"$subpkgdir"/usr/lib/
}
-md5sums="1e7e4261954275076479a08dbeae26ca bluez-4.72.tar.bz2
-66408fb89b05e7ce7e61c4c3c356d2c6 bluetooth.initd
+md5sums="75fbc768bf626fc8f4cf466006767723 bluez-4.81.tar.bz2
+c511078403d7d27673581a8bb468b90b bluetooth.initd
a159d897a057f4675548327329c4cc22 bluetooth.confd"
diff --git a/testing/bluez/bluetooth.initd b/testing/bluez/bluetooth.initd
index 9ec58e97c..ef25720bf 100644
--- a/testing/bluez/bluetooth.initd
+++ b/testing/bluez/bluetooth.initd
@@ -12,7 +12,7 @@ start() {
ebegin "Starting Bluetooth"
if [ -x /sbin/udevadm ]; then
- udevadm trigger --subsystem-match=bluetooth
+ udevadm trigger --subsystem-match=bluetooth --action=add
eend $?
fi
diff --git a/testing/gnome-bluetooth/APKBUILD b/testing/gnome-bluetooth/APKBUILD
index 0eb6e9ca9..15d3afe56 100644
--- a/testing/gnome-bluetooth/APKBUILD
+++ b/testing/gnome-bluetooth/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-bluetooth
pkgver=2.32.0
-pkgrel=0
+pkgrel=1
pkgdesc="The GNOME Bluetooth Subsystem"
url="http://live.gnome.org/GnomeBluetooth"
arch="x86 x86_64"
license="GPL LGPL"
-depends="hicolor-icon-theme obexd"
+depends="hicolor-icon-theme obexd-client obex-data-server"
makedepends="intltool py-gtk gobject-introspection libunique-dev libnotify-dev
libxi-dev libxslt py-libxml2 gnome-doc-utils"
install=
diff --git a/testing/gnome-disk-utility/APKBUILD b/testing/gnome-disk-utility/APKBUILD
new file mode 100644
index 000000000..636eace77
--- /dev/null
+++ b/testing/gnome-disk-utility/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-disk-utility
+pkgver=2.32.0
+pkgrel=0
+pkgdesc="GNOME libraries and applications for dealing with storage devices"
+url="http://www.gnome.org"
+arch="all"
+license="GPL"
+depends=""
+makedepends="gnome-doc-utils intltool dbus-glib-dev libunique-dev avahi-dev
+ udisks-dev libnotify-dev hicolor-icon-theme libatasmart-dev
+ rarian-dev libxslt"
+install=
+subpackages="$pkgname-dev $pkgname-libs $pkgname-ui-libs:uilibs"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-disk-utility/${pkgver%.*}/gnome-disk-utility-$pkgver.tar.bz2
+ fix-freeze.patch
+ exp2.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -Np1 -i "$srcdir/fix-freeze.patch"
+ patch -Np1 -i "$srcdir/exp2.patch"
+}
+
+build ()
+{
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/gnome-disk-utility \
+ --disable-scrollkeeper \
+ --disable-nautilus \
+ --disable-gtk-doc
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ pkgdesc="Shared libraries used by Palimpsest"
+ mkdir -p "$subpkgdir"/usr/lib \
+ "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/lib/libgdu.so.* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
+}
+
+uilibs() {
+ pkgdesc="Shared libraries used by Palimpsest"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libgdu-gtk.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="f0366c8baebca0404d190b2d78f3582d gnome-disk-utility-2.32.0.tar.bz2
+c0161b09b620ef9c3975db400518eb1f fix-freeze.patch
+ac7d749bb6fa2e31bffb1f47822bc22b exp2.patch"
diff --git a/testing/gnome-disk-utility/exp2.patch b/testing/gnome-disk-utility/exp2.patch
new file mode 100644
index 000000000..449980362
--- /dev/null
+++ b/testing/gnome-disk-utility/exp2.patch
@@ -0,0 +1,16 @@
+--- ./src/gdu-gtk/gdu-size-widget.c.orig
++++ ./src/gdu-gtk/gdu-size-widget.c
+@@ -564,11 +564,11 @@
+
+ shown_extent = extent / unit_factor;
+
+- increment = (exp10 (floor (log10 (shown_extent))) / 10.0) * unit_factor;
++ increment = (exp2 (floor (log2 (shown_extent))) / 2.0) * unit_factor;
+
+ gtk_range_set_increments (GTK_RANGE (widget->priv->hscale),
+ increment,
+- increment * 10.0);
++ increment * 2.0);
+ }
+
+
diff --git a/testing/gnome-disk-utility/fix-freeze.patch b/testing/gnome-disk-utility/fix-freeze.patch
new file mode 100644
index 000000000..262748bfb
--- /dev/null
+++ b/testing/gnome-disk-utility/fix-freeze.patch
@@ -0,0 +1,32 @@
+From 82489b51443e1280dfb9fb251ea2693df1809aec Mon Sep 17 00:00:00 2001
+From: Pascal Terjan <pterjan@mandriva.com>
+Date: Mon, 3 May 2010 14:01:22 +0200
+Subject: [PATCH] Force GduPresentable ids to be UTF-8 (#616198)
+
+GduPresentable created in gdu pool include intheir id some strings
+in local encoding like _("Peripheral Devices"). This patch
+enforces them to be UTF-8.
+
+This fixes a crash of gvfs-gdu-volume-monitor when USB devices are
+available on a non UTF-8 system.
+---
+ src/gdu/gdu-pool.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/gdu/gdu-pool.c b/src/gdu/gdu-pool.c
+index bd5eccf..cf6be53 100644
+--- a/src/gdu/gdu-pool.c
++++ b/src/gdu/gdu-pool.c
+@@ -473,6 +473,9 @@ gdu_pool_class_init (GduPoolClass *klass)
+ g_cclosure_marshal_VOID__OBJECT,
+ G_TYPE_NONE, 1,
+ GDU_TYPE_PRESENTABLE);
++#ifdef HAVE_BIND_TEXTDOMAIN_CODESET
++ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
++#endif
+ }
+
+ static void
+--
+1.7.1
+
diff --git a/testing/gvfs/APKBUILD b/testing/gvfs/APKBUILD
index 8699d664f..76de80a2d 100644
--- a/testing/gvfs/APKBUILD
+++ b/testing/gvfs/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gvfs
pkgver=1.6.6
-pkgrel=1
-pkgdesc="userspace virtual filesystem"
-url="http://ftp.gnome.org/pub/gnome/sources/gvfs/1.6/"
-arch="x86 x86_64"
+pkgrel=3
+pkgdesc="Backends for the gio framework in GLib"
+url="http://ftp.gnome.org/pub/gnome/sources/gvfs/${pkgver%.*}/"
+arch="all"
license="GPL"
depends=
+triggers="$pkgname.trigger:/usr/lib/gvfs"
makedepends="dbus-glib-dev intltool fuse-dev udev-dev bluez-dev expat-dev
- samba-dev libsoup-dev"
+ samba-dev libsoup-dev avahi-dev libarchive-dev gnome-disk-utility-dev"
install=
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-fuse $pkgname-smb $pkgname-archive
+ $pkgname-obexftp"
source="http://ftp.gnome.org/pub/gnome/sources/gvfs/${pkgver%.*}/gvfs-$pkgver.tar.bz2"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -23,18 +25,68 @@ build() {
cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
+ --libexecdir=/usr/lib/gvfs \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --enable-gdu \
+ --disable-gconf \
+ || return 1
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
+}
+
+_mv_files() {
+ local i
+ for i in "$@"; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ done
+}
+
+fuse() {
+ pkgdesc="FUSE support for gvfs"
+ triggers=
+ cd "$pkgdir"
+ _mv_files usr/lib/gvfs/gvfs-fuse-daemon
+}
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+smb() {
+ pkgdesc="Windows fileshare support for gvfs"
+ triggers=
+ cd "$pkgdir"
+ _mv_files \
+ usr/lib/gvfs/gvfsd-smb* \
+ usr/share/gvfs/mounts/smb*
}
+archive() {
+ pkgdesc="Archiving support for gvfs"
+ triggers=
+ cd "$pkgdir"
+ _mv_files \
+ usr/lib/gvfs/gvfsd-archive* \
+ usr/share/gvfs/mounts/archive*
+}
+
+obexftp() {
+ pkgdesc="ObexFTP support for gvfs"
+ triggers=
+ cd "$pkgdir"
+ _mv_files \
+ usr/lib/gvfs/gvfsd-obex* \
+ usr/share/gvfs/mounts/obex*
+}
+
+#gphoto2() {
+# pkgdesc="gphoto2 support for gvfs"
+#}
+#
+#afc() {
+# pkgdesc="AFC support for gvfs"
+#}
+
md5sums="e1f324c45ea07d630f85bd3199865fd9 gvfs-1.6.6.tar.bz2"
diff --git a/testing/gvfs/gvfs.trigger b/testing/gvfs/gvfs.trigger
new file mode 100644
index 000000000..e1d790682
--- /dev/null
+++ b/testing/gvfs/gvfs.trigger
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+# Reload .mount files
+killall -USR1 gvfsd >&/dev/null
+exit 0
+
diff --git a/testing/libarchive/APKBUILD b/testing/libarchive/APKBUILD
new file mode 100644
index 000000000..28a1cbc81
--- /dev/null
+++ b/testing/libarchive/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libarchive
+pkgver=2.8.4
+pkgrel=1
+pkgdesc="library that can create and read several streaming archive formats"
+url="http://libarchive.googlecode.com/"
+arch="all"
+license="BSD"
+depends=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+makedepends="zlib-dev bzip2-dev xz-dev acl-dev openssl-dev expat-dev"
+depends_dev="$makedepends"
+source="http://libarchive.googlecode.com/files/libarchive-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build () {
+ cd "$_builddir"
+ ./configure --prefix=/usr --without-xml2
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ pkgdesc="libarchive tools bsdtar and bsdcpio"
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="83b237a542f27969a8d68ac217dc3796 libarchive-2.8.4.tar.gz"
diff --git a/testing/libdaemon/APKBUILD b/testing/libdaemon/APKBUILD
new file mode 100644
index 000000000..7a39c98df
--- /dev/null
+++ b/testing/libdaemon/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libdaemon
+pkgver=0.14
+pkgrel=0
+pkgdesc="A lightweight C library which eases the writing of UNIX daemons"
+url="http://0pointer.de/lennart/projects/libdaemon/"
+arch="all"
+license="LGPL"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://0pointer.de/lennart/projects/libdaemon/libdaemon-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build () {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --disable-lynx \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="509dc27107c21bcd9fbf2f95f5669563 libdaemon-0.14.tar.gz"
diff --git a/testing/lua-sec/APKBUILD b/testing/lua-sec/APKBUILD
new file mode 100644
index 000000000..5d50486b2
--- /dev/null
+++ b/testing/lua-sec/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-sec
+_name=luasec
+pkgver=0.4
+pkgrel=0
+pkgdesc="TLS/SSL Support for Lua"
+url="http://www.inf.puc-rio.br/~brunoos/luasec/"
+arch="x86 x86_64"
+license="MIT"
+depends="lua-socket"
+makedepends="lua-dev openssl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://www.inf.puc-rio.br/~brunoos/luasec/download/luasec-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_name-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make linux || return 1
+}
+
+package() {
+ _luasharedir=/usr/share/lua/5.1
+ _lualibdir=/usr/lib/lua/5.1
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/$_luasharedir "$pkgdir"/$_lualibdir
+ make LUAPATH="$pkgdir"/$_luasharedir \
+ LUACPATH="$pkgdir"/$_lualibdir \
+ install
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ cp -r samples "$pkgdir"/usr/share/doc/$pkgname/
+}
+
+md5sums="712158d60207bdbb6215fc7e07d8db24 luasec-0.4.tar.gz"
diff --git a/testing/obex-data-server/APKBUILD b/testing/obex-data-server/APKBUILD
new file mode 100644
index 000000000..d0ea7f2b1
--- /dev/null
+++ b/testing/obex-data-server/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=obex-data-server
+pkgver=0.4.5
+pkgrel=0
+pkgdesc="D-Bus service for Obex access"
+url="http://wiki.muiline.com/obex-data-server"
+license="GPLv2+"
+arch="all"
+depends="!obexd"
+subpackages="$pkgname-doc"
+makedepends="dbus-glib-dev openobex-dev gtk+-dev libusb-compat-dev bluez-dev"
+source="http://tadas.dailyda.com/software/obex-data-server-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-bip=gdk-pixbuf
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="8b11e7527c1e3a36a2a9a0c52816ec7b obex-data-server-0.4.5.tar.gz"
diff --git a/testing/obexd/APKBUILD b/testing/obexd/APKBUILD
index 659a1faad..acc2ef5c3 100644
--- a/testing/obexd/APKBUILD
+++ b/testing/obexd/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=obexd
-pkgver=0.33
-pkgrel=0
-pkgdesc="D-Bus service providing high-level OBEX client and server side functionality"
+pkgver=0.37
+pkgrel=2
+pkgdesc="D-Bus service for Obex Server"
url="http://www.bluez.org/"
arch="x86 x86_64"
license="GPL2"
-depends=
+depends="!obex-data-server"
+subpackages="$pkgname-client"
makedepends="dbus-glib-dev openobex-dev glib-dev bluez-dev libical-dev"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
@@ -23,4 +24,21 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
-md5sums="3926bbe252500a5b677105f5bd41b820 obexd-0.33.tar.bz2"
+
+_mv_files() {
+ local i
+ for i in "$@"; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ done
+}
+
+client() {
+ pkgdesc="D-Bus service for Obex Client access"
+ depends=
+ cd "$pkgdir"
+ _mv_files usr/lib/obexd/obex-client \
+ usr/share/dbus-*/services/obex-client.service
+}
+
+md5sums="3126eced7f9d36aa52c3684bb31421e8 obexd-0.37.tar.bz2"
diff --git a/testing/openobex/APKBUILD b/testing/openobex/APKBUILD
index 0ad92cc24..fc7e48f42 100644
--- a/testing/openobex/APKBUILD
+++ b/testing/openobex/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openobex
pkgver=1.5
-pkgrel=0
+pkgrel=2
pkgdesc="Implementation of the OBject EXchange (OBEX) protocol"
url="http://dev.zuckschwerdt.org/openobex/"
arch="x86 x86_64"
license="GPL LGPL"
depends=
-makedepends="bluez-dev libusb-dev"
+depends_dev="libusb-compat-dev"
+makedepends="bluez-dev libusb-compat-dev"
subpackages="$pkgname-dev libopenobex"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
diff --git a/testing/psmisc/APKBUILD b/testing/psmisc/APKBUILD
new file mode 100644
index 000000000..3e3eef891
--- /dev/null
+++ b/testing/psmisc/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=psmisc
+pkgver=22.13
+pkgrel=0
+pkgdesc="a set of some small useful utilities that use the proc filesystem"
+url="http://psmisc.sourceforge.net/"
+arch="x86 x86_64"
+license="BSD GPL"
+depends=
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/psmisc/psmisc-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="e2c339e6b65b730042084023784a729e psmisc-22.13.tar.gz"
diff --git a/testing/xz/APKBUILD b/testing/xz/APKBUILD
new file mode 100644
index 000000000..b28637630
--- /dev/null
+++ b/testing/xz/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xz
+pkgver=5.0.0
+pkgrel=0
+pkgdesc="Library and command line tools for XZ and LZMA compressed files"
+url="http://tukaani.org/xz/"
+arch="all"
+license="GPL LGPL custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://tukaani.org/xz/xz-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-rpath \
+ --enable-werror
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ pkgdesc="Libraries for decoding LZMA compression"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="f3c0706d100ad2b6d63327584d026c50 xz-5.0.0.tar.gz"