summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-17 22:25:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-17 22:25:48 +0000
commitc1b34e58171d24b7a2a4c5918d75ad63e359dc12 (patch)
treeb418e9a4f0de8189929f939763865db42f0d5171 /testing
parent95cc26e35969b9a32edd2573f278fca8f96da669 (diff)
downloadaports-c1b34e58171d24b7a2a4c5918d75ad63e359dc12.tar.bz2
aports-c1b34e58171d24b7a2a4c5918d75ad63e359dc12.tar.xz
testing/obexd: separate client package
Diffstat (limited to 'testing')
-rw-r--r--testing/obexd/APKBUILD21
1 files changed, 19 insertions, 2 deletions
diff --git a/testing/obexd/APKBUILD b/testing/obexd/APKBUILD
index f75b37a46..64913477c 100644
--- a/testing/obexd/APKBUILD
+++ b/testing/obexd/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=obexd
pkgver=0.37
-pkgrel=0
-pkgdesc="D-Bus service providing high-level OBEX client and server side functionality"
+pkgrel=1
+pkgdesc="D-Bus service for Obex Server"
url="http://www.bluez.org/"
arch="x86 x86_64"
license="GPL2"
depends=
+subpackages="$pkgname-client"
makedepends="dbus-glib-dev openobex-dev glib-dev bluez-dev libical-dev"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
@@ -23,4 +24,20 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
+
+_mv_files() {
+ local i
+ for i in "$@"; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ done
+}
+
+client() {
+ pkgdesc="D-Bus service for Obex Client access"
+ cd "$pkgdir"
+ _mv_files usr/lib/obexd/obex-client \
+ usr/share/dbus-*/services/obex-client.service
+}
+
md5sums="3126eced7f9d36aa52c3684bb31421e8 obexd-0.37.tar.bz2"