summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-11-02 14:32:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-11-02 15:23:04 +0000
commitb12fa141851bd5d4c9fec0db3d2cd3643b74c608 (patch)
tree6795720bef714b7fd4969be0807db331af5be706 /testing
parent184bfa7d3b0bf96fdbaab4670fbb1b29ae510637 (diff)
downloadaports-b12fa141851bd5d4c9fec0db3d2cd3643b74c608.tar.bz2
aports-b12fa141851bd5d4c9fec0db3d2cd3643b74c608.tar.xz
testing/swish-e: separate package() function
Diffstat (limited to 'testing')
-rw-r--r--testing/swish-e/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/swish-e/APKBUILD b/testing/swish-e/APKBUILD
index 758d77551..03a2b384b 100644
--- a/testing/swish-e/APKBUILD
+++ b/testing/swish-e/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Simple Web Indexing System for Humans - Enhanced"
url="http://www.swish-e.org/"
license="GPL"
depends=""
-makedepends=""
+makedepends="perl-dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.swish-e.org/distribution/$pkgname-$pkgver.tar.gz"
@@ -20,6 +20,10 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}