summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-29 07:21:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-29 07:21:49 +0000
commitdd53fe7f4255eee439f44f0c12a51eb4cbb819bc (patch)
tree3a3b56e990cb07c162c0b5f1e3f8f5561ed6ab72 /testing
parentc267e84cb40c03316907d16aca91fd8c0fcf2b03 (diff)
downloadaports-dd53fe7f4255eee439f44f0c12a51eb4cbb819bc.tar.bz2
aports-dd53fe7f4255eee439f44f0c12a51eb4cbb819bc.tar.xz
testing/thunar-vcs-plugin: fix linking to apr and fix libexec dir
Diffstat (limited to 'testing')
-rw-r--r--testing/thunar-vcs-plugin/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/thunar-vcs-plugin/APKBUILD b/testing/thunar-vcs-plugin/APKBUILD
index 8485b16fa..303044f81 100644
--- a/testing/thunar-vcs-plugin/APKBUILD
+++ b/testing/thunar-vcs-plugin/APKBUILD
@@ -22,11 +22,14 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ # quick and dirty fix for apr linking
+ sed -i -e 's/APR_LDFLAGS/APR_LIBS/' thunar-vcs-plugin/Makefile.in
}
build() {
cd "$_builddir"
./configure --prefix=/usr \
+ --libexecdir=/usr/lib/xfce4 \
--disable-static \
--enable-subversion \
--enable-git \
@@ -53,7 +56,7 @@ _git() {
depends=
install_if="thunar-vcs-plugin git"
cd "$pkgdir"
- _mv_files usr/libexec/tvp-git-helper \
+ _mv_files usr/lib/xfce4/tvp-git-helper \
usr/share/icons/hicolor/*/apps/git.png
}
@@ -62,7 +65,7 @@ _svn() {
depends=
install_if="thunar-vcs-plugin subversion"
cd "$pkgdir"
- _mv_files usr/libexec/tvp-svn-helper \
+ _mv_files usr/lib/xfce4/tvp-svn-helper \
usr/share/icons/hicolor/*/apps/subversion.png
}