summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-07 21:58:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-07 21:58:20 +0000
commit45ae46bf4d1ff033457018d4ddac1bd1a484bf12 (patch)
tree47ea6167e6635f51d9e07dc42e67507899204c77 /testing
parentfeb0a88266b0bbd67f9cd7d747596e7f8158f4a7 (diff)
downloadaports-45ae46bf4d1ff033457018d4ddac1bd1a484bf12.tar.bz2
aports-45ae46bf4d1ff033457018d4ddac1bd1a484bf12.tar.xz
testing/ttf-freefont: new aport
A set of free high-quality TrueType fonts covering the UCS character set http://www.nongnu.org/freefont/
Diffstat (limited to 'testing')
-rw-r--r--testing/ttf-freefont/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/ttf-freefont/APKBUILD b/testing/ttf-freefont/APKBUILD
new file mode 100644
index 000000000..6ec0683fb
--- /dev/null
+++ b/testing/ttf-freefont/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ttf-freefont
+pkgver=20100919
+pkgrel=0
+pkgdesc="A set of free high-quality TrueType fonts covering the UCS character set"
+url="http://www.nongnu.org/freefont/"
+arch="noarch"
+license="GPL"
+depends="fontconfig encodings mkfontdir mkfontscale"
+makedepends="pkgconfig font-util-dev"
+install=
+source="http://ftp.gnu.org/gnu/freefont/freefont-ttf-$pkgver.tar.gz"
+
+_builddir="$srcdir/freefont-$pkgver"
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
+
+md5sums="33d96c755d0a6f585bc917f08cbddf66 freefont-ttf-20100919.tar.gz"