summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-10-19 07:33:39 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-10-19 07:33:39 +0000
commit25eb0d5237c26d92c994c5b35e58c0bfdc73b6ef (patch)
tree5e6f1c7237dc370365f3d75978ad37fdc5c95f57 /testing
parent90b7d529aeac4b6f4c3792772baa6cc4e5e69f7a (diff)
downloadaports-25eb0d5237c26d92c994c5b35e58c0bfdc73b6ef.tar.bz2
aports-25eb0d5237c26d92c994c5b35e58c0bfdc73b6ef.tar.xz
testing/ntop: ntop user and internal db dir added
Diffstat (limited to 'testing')
-rw-r--r--testing/ntop/APKBUILD7
-rwxr-xr-xtesting/ntop/ntop.post-install3
2 files changed, 7 insertions, 3 deletions
diff --git a/testing/ntop/APKBUILD b/testing/ntop/APKBUILD
index 530edfff8..cfcee710d 100644
--- a/testing/ntop/APKBUILD
+++ b/testing/ntop/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname=ntop
pkgver=4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Network traffic probe"
url="http://www.ntop.org"
license="GPL"
@@ -10,7 +10,7 @@ depends=
makedepends="autoconf automake freetype-dev gdbm-dev geoip-dev libart-lgpl-dev
libevent-dev libpcap-dev libpng-dev libtool libxml2-dev lua-dev
openssl-dev python-dev rrdtool-dev wget zlib-dev"
-install=
+install="$pkgname.post-install"
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz
ntop.initd
@@ -38,11 +38,12 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
- # remove the 2 lines below (and this) if there is no init.d script
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
install -m755 -D "$srcdir"/ntop-update-geoip-db \
"$pkgdir"/usr/bin/ntop-update-geoip-db
+ # ntop internal db dir
+ mkdir -p $pkgdir/var/lib/ntop
}
md5sums="c5fc7863d8ba08654ef7b4d88ff860f4 ntop-4.0.tar.gz
diff --git a/testing/ntop/ntop.post-install b/testing/ntop/ntop.post-install
new file mode 100755
index 000000000..ede8a22f3
--- /dev/null
+++ b/testing/ntop/ntop.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+adduser -h /var/lib/ntop -s /bin/false -S -H -D ntop &>/dev/null
+chown ntop /var/lib/ntop