summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-20 16:44:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-20 16:44:53 +0000
commit2db6c6cae02eeead53b9ad09da0087c928bc29de (patch)
tree249de5e9389f53108dba33b750ef60c1000978a3 /testing
parent7585763f3d3a6ac3f52b8fe4a526da45100ea7ea (diff)
downloadaports-2db6c6cae02eeead53b9ad09da0087c928bc29de.tar.bz2
aports-2db6c6cae02eeead53b9ad09da0087c928bc29de.tar.xz
testing/fail2ban: add init.d script and logrotate
fixes #583
Diffstat (limited to 'testing')
-rw-r--r--testing/fail2ban/APKBUILD21
-rw-r--r--testing/fail2ban/fail2ban.confd8
-rw-r--r--testing/fail2ban/fail2ban.logrotate9
-rw-r--r--testing/fail2ban/gentoo-initd_create_run_dir.patch19
4 files changed, 53 insertions, 4 deletions
diff --git a/testing/fail2ban/APKBUILD b/testing/fail2ban/APKBUILD
index 7a20ad4c2..8a770f60e 100644
--- a/testing/fail2ban/APKBUILD
+++ b/testing/fail2ban/APKBUILD
@@ -2,15 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fail2ban
pkgver=0.8.4
-pkgrel=0
+pkgrel=1
pkgdesc="Scans log files for login failures then updates iptables to reject originating ip address"
url="http://www.fail2ban.org"
arch="noarch"
license="GPLv2"
-depends="python iptables"
+depends="python iptables logrotate"
makedepends="python-dev"
install=""
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
+ gentoo-initd_create_run_dir.patch
+ fail2ban.confd
+ fail2ban.logrotate
+ "
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -30,6 +34,15 @@ build() {
package() {
cd "$_builddir"
python setup.py install --root "$pkgdir" || return 1
+ install -Dm755 files/gentoo-initd "$pkgdir"/etc/init.d/fail2ban \
+ || return 1
+ install -Dm644 "$srcdir"/fail2ban.confd "$pkgdir"/etc/conf.d/fail2ban \
+ || return 1
+ install -Dm644 "$srcdir"/fail2ban.logrotate \
+ "$pkgdir"/etc/logrotate.d/fail2ban || return 1
}
-md5sums="df94335a5d12b4750869e5fe350073fa fail2ban-0.8.4.tar.bz2"
+md5sums="df94335a5d12b4750869e5fe350073fa fail2ban-0.8.4.tar.bz2
+61580eb6d8d9a4d187e97bc27f2fcb1e gentoo-initd_create_run_dir.patch
+b209a04f9314dd064a4aa0ee505c8a4d fail2ban.confd
+6d1af6ceebd15c8ae3938bc675efe553 fail2ban.logrotate"
diff --git a/testing/fail2ban/fail2ban.confd b/testing/fail2ban/fail2ban.confd
new file mode 100644
index 000000000..3c957b922
--- /dev/null
+++ b/testing/fail2ban/fail2ban.confd
@@ -0,0 +1,8 @@
+# Config file for /etc/init.d/fail2ban
+
+# For information on options, see "/usr/bin/fail2ban-client -h".
+
+FAIL2BAN_OPTIONS=""
+
+# Force execution of the server even if the socket already exists:
+#FAIL2BAN_OPTIONS="-x"
diff --git a/testing/fail2ban/fail2ban.logrotate b/testing/fail2ban/fail2ban.logrotate
new file mode 100644
index 000000000..5d22bd039
--- /dev/null
+++ b/testing/fail2ban/fail2ban.logrotate
@@ -0,0 +1,9 @@
+/var/log/fail2ban.log {
+ daily
+ rotate 7
+ missingok
+ compress
+ postrotate
+ /usr/bin/fail2ban-client set logtarget /var/log/fail2ban.log 1>/dev/null || true
+ endscript
+}
diff --git a/testing/fail2ban/gentoo-initd_create_run_dir.patch b/testing/fail2ban/gentoo-initd_create_run_dir.patch
new file mode 100644
index 000000000..79a947956
--- /dev/null
+++ b/testing/fail2ban/gentoo-initd_create_run_dir.patch
@@ -0,0 +1,19 @@
+Index: fail2ban-0.8.4/files/gentoo-initd
+===================================================================
+--- fail2ban-0.8.4.orig/files/gentoo-initd
++++ fail2ban-0.8.4/files/gentoo-initd
+@@ -31,6 +31,14 @@ depend() {
+
+ start() {
+ ebegin "Starting fail2ban"
++ if [ ! -d /var/run/fail2ban ]; then
++ mkdir /var/run/fail2ban || return 1
++ fi
++ if [ -e /var/run/fail2ban/fail2ban.sock ]; then
++ # remove stalled sock file after system crash
++ # bug 347477
++ rm -rf /var/run/fail2ban/fail2ban.sock || return 1
++ fi
+ ${FAIL2BAN} start &> /dev/null
+ eend $? "Failed to start fail2ban"
+ }