summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-27 10:12:24 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-27 10:12:24 +0000
commit3f7c4a9bd7b19c08bc2be8e68dc8cdd6d6ff3519 (patch)
tree40e6199db8a10cbbfb99c2a688a34c5ae2ea4c68 /testing
parent874b9df45561e9ee6268c24c81f35933864ea494 (diff)
downloadaports-3f7c4a9bd7b19c08bc2be8e68dc8cdd6d6ff3519.tar.bz2
aports-3f7c4a9bd7b19c08bc2be8e68dc8cdd6d6ff3519.tar.xz
testing/tvheadend-git: new snapshot
Diffstat (limited to 'testing')
-rw-r--r--testing/tvheadend-git/APKBUILD32
-rw-r--r--testing/tvheadend-git/tvheadend-git.initd9
2 files changed, 16 insertions, 25 deletions
diff --git a/testing/tvheadend-git/APKBUILD b/testing/tvheadend-git/APKBUILD
index 81262eba7..095e6f906 100644
--- a/testing/tvheadend-git/APKBUILD
+++ b/testing/tvheadend-git/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=tvheadend-git
-pkgver=20121204
+pkgver=0_git20130127
pkgrel=0
pkgdesc="TV Streaming server for linux"
url="http://www.lonelycoder.com/hts/tvheadend_overview.html"
arch="all"
license="GPL3"
depends=""
-depends_dev="openssl-dev libdvbcsa-dev"
+depends_dev="openssl-dev libdvbcsa-dev ffmpeg-dev curl-dev"
makedepends="$depends_dev python findutils bash"
pkgusers="$pkgname"
pkggroups="$pkgname"
@@ -17,28 +17,10 @@ subpackages="$pkgname-doc"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd"
-_giturl="git://github.com/tvheadend/tvheadend.git"
-_upload="dev.alpinelinux.org:/archive/$pkgname/"
-_builddir="$srcdir/$pkgname-$pkgver"
+giturl="git://github.com/tvheadend/tvheadend.git"
+disturl="dev.alpinelinux.org:/archive/$pkgname/"
-snapshot() {
- local _date=$(date +%Y%m%d)
- local _pkg=$pkgname-$_date.tar.gz
- mkdir -p "$srcdir"
- cd "$srcdir"
- msg "Creating snapshot: $_pkg"
- rm -rf ${_giturl##*/}
- git clone --depth=1 --bare $_giturl || return 1
- git --git-dir ${_giturl##*/} archive -o $_pkg \
- --prefix=$pkgname-$_date/ HEAD \
- || return 1
- msg "Uploading to $_upload"
- rsync -Lave ssh $_pkg $_upload || return 1
- cd "$startdir"
- sed -i -e "s/^pkgver=.*/pkgver=$_date/" \
- APKBUILD || return 1
- abuild checksum
-}
+_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
local i
@@ -75,6 +57,6 @@ package() {
"$pkgdir/etc/$pkgname" || return 1
}
-md5sums="abfa68adafb04964263a928934cee2f1 tvheadend-git-20121204.tar.gz
-8b7da39441150596bdeb2456f7cf73ed tvheadend-git.initd
+md5sums="173586555ce2d3a006bcfcd79666568c tvheadend-git-0_git20130127.tar.gz
+c68694d41e7ce0d94913e4332c060618 tvheadend-git.initd
17cf7dfaf27706409a004c246c1a2c3c tvheadend-git.confd"
diff --git a/testing/tvheadend-git/tvheadend-git.initd b/testing/tvheadend-git/tvheadend-git.initd
index 9b56313a8..b72df3378 100644
--- a/testing/tvheadend-git/tvheadend-git.initd
+++ b/testing/tvheadend-git/tvheadend-git.initd
@@ -6,6 +6,9 @@ depend() {
start() {
ebegin "Starting tvheadend"
+
+ checkconf || return 1
+
start-stop-daemon --start \
--exec ${TVHBIN} -- \
-C -f -u ${TVHUSER} \
@@ -21,3 +24,9 @@ stop() {
eend $?
}
+checkconf() {
+ if [ ! -d "$TVHCONF" ]; then
+ eerror "config directory does not exist!"
+ return 1
+ fi
+}