summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-15 09:12:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-16 22:39:46 +0000
commit5b91c245552abbbf05a0d7960444b9ca63a33e1c (patch)
tree9c3301f36f9ab41f3ef7dbb44e4cf45eba2adfea /testing
parente88f93b4503ed7e519ed17bbfce926503a3a37a1 (diff)
downloadaports-5b91c245552abbbf05a0d7960444b9ca63a33e1c.tar.bz2
aports-5b91c245552abbbf05a0d7960444b9ca63a33e1c.tar.xz
testing/hardinfo: alpine and uclibc fixes
Diffstat (limited to 'testing')
-rw-r--r--testing/hardinfo/APKBUILD14
-rw-r--r--testing/hardinfo/hardinfo-alpine.patch2
-rw-r--r--testing/hardinfo/uclibc.patch22
3 files changed, 33 insertions, 5 deletions
diff --git a/testing/hardinfo/APKBUILD b/testing/hardinfo/APKBUILD
index f4eec282c..97cc68b48 100644
--- a/testing/hardinfo/APKBUILD
+++ b/testing/hardinfo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hardinfo
pkgver=0.5.1
-pkgrel=2
+pkgrel=3
pkgdesc="A system information and benchmark tool."
url="http://hardinfo.berlios.de/wiki/index.php/Main_Page"
arch="all"
@@ -10,13 +10,18 @@ makedepends="gtk+-dev libsoup-dev>=2.4.0 gnutls-dev>=2.4.1"
depends=
source="http://download.berlios.de/$pkgname/$pkgname-$pkgver.tar.bz2
fixsensors.patch
+ uclibc.patch
hardinfo-alpine.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 -i "$srcdir"/fixsensors.patch || return 1
- patch -p1 -i "$srcdir"/hardinfo-alpine.patch || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
# configure scrip says bash but bb ash works just fine
sed -i -e '1,1s/bash/sh/' configure
}
@@ -35,4 +40,5 @@ package() {
}
md5sums="6fb38992e140f2fab16518ae1f38e188 hardinfo-0.5.1.tar.bz2
05c212db07b9f152cdea052ff7bb28fa fixsensors.patch
-ae8d38e5b35fb2c9c5f425dde3ba27cb hardinfo-alpine.patch"
+e5dfccb5d3cb46acd36072f9e2396ff4 uclibc.patch
+41651eb55dc219b6d9c279227a17514a hardinfo-alpine.patch"
diff --git a/testing/hardinfo/hardinfo-alpine.patch b/testing/hardinfo/hardinfo-alpine.patch
index 279aa5d53..47e3cb73a 100644
--- a/testing/hardinfo/hardinfo-alpine.patch
+++ b/testing/hardinfo/hardinfo-alpine.patch
@@ -4,7 +4,7 @@
static struct {
gchar *file, *codename;
} distro_db[] = {
-+ { DB_PREFIX "alpine-version", "al" },
++ { DB_PREFIX "alpine-release", "al" },
{ DB_PREFIX "debian_version", "deb" },
{ DB_PREFIX "slackware-version", "slk" },
{ DB_PREFIX "mandrake-release", "mdk" },
diff --git a/testing/hardinfo/uclibc.patch b/testing/hardinfo/uclibc.patch
new file mode 100644
index 000000000..c24e9ea1a
--- /dev/null
+++ b/testing/hardinfo/uclibc.patch
@@ -0,0 +1,22 @@
+diff --git a/arch/linux/common/os.h b/arch/linux/common/os.h
+index f3c2c2d..78bc78b 100644
+--- a/arch/linux/common/os.h
++++ b/arch/linux/common/os.h
+@@ -49,6 +49,9 @@ err:
+ static gchar *
+ get_libc_version(void)
+ {
++#if defined(__UCLIBC__)
++ return g_strdup("uClibc");
++#else
+ FILE *libc;
+ gchar buf[256], *tmp, *p;
+
+@@ -70,6 +73,7 @@ get_libc_version(void)
+ strstr(buf, " stable ") ? "" : "un");
+ err:
+ return g_strdup("Unknown");
++#endif
+ }
+
+ static gchar *