summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-01-24 15:43:20 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-01-24 15:44:35 +0000
commite0fdd6a073ecac2ae6b22ff04085b08ee8a7999a (patch)
treec7d64e43c4a36e89ea015829450b22d3e73947f0 /testing
parentcf3615073538e94f81acfbf5a603df84e1aa4512 (diff)
downloadaports-e0fdd6a073ecac2ae6b22ff04085b08ee8a7999a.tar.bz2
aports-e0fdd6a073ecac2ae6b22ff04085b08ee8a7999a.tar.xz
testing/fprobe-ulog: new aport
Netfilter-based tool that collect network traffic
Diffstat (limited to 'testing')
-rw-r--r--testing/fprobe-ulog/APKBUILD49
-rw-r--r--testing/fprobe-ulog/fprobe-ulog.confd68
-rwxr-xr-xtesting/fprobe-ulog/fprobe-ulog.initd39
3 files changed, 156 insertions, 0 deletions
diff --git a/testing/fprobe-ulog/APKBUILD b/testing/fprobe-ulog/APKBUILD
new file mode 100644
index 000000000..750375918
--- /dev/null
+++ b/testing/fprobe-ulog/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=fprobe-ulog
+pkgver=1.1
+pkgrel=0
+pkgdesc="netfilter-based tool that collect network traffic"
+url="http://fprobe.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/fprobe/$pkgname/$pkgver/$pkgname-1.1.tar.bz2
+ fprobe-ulog.confd
+ fprobe-ulog.initd
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd $_builddir
+# for i in ../*.patch
+# do
+# msg "Applying $i"
+# patch -p1 < ../$i || exit 1
+# done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+
+}
+
+md5sums="cdb2e4edc47e8a3d5479eeabfb979ebc fprobe-ulog-1.1.tar.bz2
+a92104da52c99532d1d01007b78940fc fprobe-ulog.confd
+bc878e47b44fbd71bd594206a4384c12 fprobe-ulog.initd"
diff --git a/testing/fprobe-ulog/fprobe-ulog.confd b/testing/fprobe-ulog/fprobe-ulog.confd
new file mode 100644
index 000000000..758d97f46
--- /dev/null
+++ b/testing/fprobe-ulog/fprobe-ulog.confd
@@ -0,0 +1,68 @@
+# Config file for /etc/init.d/fprobe
+DAEMON=/usr/sbin/fprobe-ulog
+
+# Do we want the interface in promiscous mode [yes/no]
+#PROMISC=no
+
+# If configured, only capture packets matching this tcpdump expression
+#FILTER=""
+
+# Flow state timers
+#TIMER_EXPIRED=5
+#TIMER_FRAGMENTED=30
+#TIMER_IDLE=60
+#TIMER_ACTIVE=300
+
+# This is the default and should be left unless you know what you are doing
+#FLOW_VER=5
+
+# local ip. if configured fprobe will use this as the source IP for sending ALL flow data
+# If you want to specify a specific source address per collecter, customize it below
+#LOCALIP=
+
+# SNMP iface id
+SNMP_IFACE="${IFACE//eth}"
+
+# Maximum number of concurrent flows to track
+# using a specified amount of memory
+#MEMBULK=10000
+#MEMLIMIT=
+
+# Pending queue
+#PENDING=100
+
+# Kernel capture buffer size (kB)
+#KERNBUF=1024
+
+# Realtime priority [0=disabled, 1..99]
+#RTPRIO=0
+
+# Delay N nanoseconds after each B bytes
+#DELAY="0:0"
+
+# How much of the start of each packet to grab
+#SNAPLEN=256
+
+# chroot() to this location after startup
+CHROOT="/var/empty"
+
+# User to run as. must have perms to the pidfile directory /var/run/fprobe/
+USER=nobody
+
+# logging level for syslog (0=EMERG, ..., 6=INFO, 7=DEBUG)
+#LOGLEVEL=6
+
+# If you want to run multiple instances of fprobe,
+# You MUST set this variable to a unique INTEGER for each one!
+PIDFILE_ID=''
+
+# remote ip. this is where we send flows
+REMOTEIP=127.0.0.1
+# port to listen on
+PORT=2055
+# Collector type, see the manpage for valid types
+TYPE=''
+
+# If you want multiple collectors, just specify each one here
+COLLECTORS="${REMOTEIP}:${PORT}/${LOCALIP}/${TYPE}"
+
diff --git a/testing/fprobe-ulog/fprobe-ulog.initd b/testing/fprobe-ulog/fprobe-ulog.initd
new file mode 100755
index 000000000..f79579484
--- /dev/null
+++ b/testing/fprobe-ulog/fprobe-ulog.initd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+ after firewall
+}
+
+PIDFILE_EXTRA=""
+[ -n "$PIDFILE_ID" ] && PIDFILE_EXTRA="[$PIDFILE_ID]"
+PIDFILE="/var/run/fprobe$PIDFILE_EXTRA.pid"
+
+start() {
+ ebegin "Starting fprobe"
+ local OPTS=""
+ set --
+ [ -n "${FILTER}" ] && set -- -f "${FILTER}"
+ for optname in s:TIMER_EXPIRED g:TIME_FRAGMENTED d:TIMER_IDLE \
+ e:TIMER_ACTIVE n:FLOW_VER a:LOCALIP X:SNMP_IFACE b:MEMBULK \
+ m:MEMLIMIT q:PENDING B:KERNBUF r:RTPRIO t:DELAY \
+ c:CHROOT u:USER v:LOGLEVEL ; do
+ opt="${optname/:*}" optvar="${optname/*:}"
+ eval optvalue="\$$optvar"
+ [ -n "$optvalue" ] && OPTS="${OPTS} -${opt} ${optvalue}"
+ done
+ OPTS="${OPTS} -l 1:${PIDFILE_ID} ${COLLECTORS}"
+ start-stop-daemon --start --exec $DAEMON \
+ --pidfile ${PIDFILE} \
+ -- "$@" ${OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping fprobe"
+ start-stop-daemon --stop --quiet --exec $DAEMON \
+ --pidfile ${PIDFILE}
+ eend $?
+}