summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-25 19:54:05 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-25 19:54:05 +0000
commit41a9c2738b72cd16ea0d328caeff9cdcf5870460 (patch)
treeb7e865fa7b4454e8ef0da82627c0f774580dffda /unstable
parent615d2cc07d0670b067225881a43352c58f4e2205 (diff)
downloadaports-41a9c2738b72cd16ea0d328caeff9cdcf5870460.tar.bz2
aports-41a9c2738b72cd16ea0d328caeff9cdcf5870460.tar.xz
unstable/hypermail Initial Commit
Diffstat (limited to 'unstable')
-rw-r--r--unstable/hypermail/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/unstable/hypermail/APKBUILD b/unstable/hypermail/APKBUILD
new file mode 100644
index 000000000..694ff92a7
--- /dev/null
+++ b/unstable/hypermail/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=hypermail
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Mail Archiver"
+url="http://www.hypermail-project.org"
+license="GPL"
+depends="uclibc pcre"
+makedepends="pcre-dev bison"
+install=
+subpackages=""
+source="http://www.hypermail-project.org/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-httpddir=/var/www \
+ --with-cgidir=/var/www/cgi-bin
+ make || return 1
+ #does not understand DESTDIR so going to install ourselves
+ #make DESTDIR="$pkgdir" install
+
+ install -m755 -D archive/rdmsg "$pkgdir"/usr/bin/rdmsg
+ install -m755 -D archive/msg2archive "$pkgdir"/usr/bin/msgarchive
+ install -m755 -D src/hypermail "$pkgdir"/usr/bin/hypermail
+
+}
+
+md5sums="a064e36780ee41409c8c973f9c69927f hypermail-2.2.0.tar.gz"