summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-25 22:58:07 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-25 22:58:07 +0000
commit708332729740e2d54c18d71d2cacbe20d65f7cc2 (patch)
tree99d3d1c3bfe45135530c500fc22040bc5a59aa38 /unstable
parent6a808336997837ae8f8a711d6ebf3ba966953bd7 (diff)
downloadaports-708332729740e2d54c18d71d2cacbe20d65f7cc2.tar.bz2
aports-708332729740e2d54c18d71d2cacbe20d65f7cc2.tar.xz
unstable/haproxy Initial commit
Diffstat (limited to 'unstable')
-rw-r--r--unstable/haproxy/APKBUILD8
-rw-r--r--unstable/haproxy/haproxy.initd44
2 files changed, 48 insertions, 4 deletions
diff --git a/unstable/haproxy/APKBUILD b/unstable/haproxy/APKBUILD
index 2f61f5642..d37caf880 100644
--- a/unstable/haproxy/APKBUILD
+++ b/unstable/haproxy/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=haproxy
-pkgver=1.3.17
+pkgver=1.3.20
pkgrel=0
pkgdesc="A TCP/HTTP reverse proxy for high availability environments"
url="http://haproxy.1wt.eu"
license="GPL"
-depends="uclibc"
+depends=""
makedepends=""
install=
subpackages=""
@@ -17,11 +17,11 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
make TARGET=linux26 || return 1
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" PREFIX=/usr install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
# install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-md5sums="423ad955828a2de1803410a4405696f2 haproxy-1.3.17.tar.gz
+md5sums="e37046e0cb2f407d92c41d7731d1dd10 haproxy-1.3.20.tar.gz
a7c6178dc4078fa233084ee36c8b440c haproxy.initd"
diff --git a/unstable/haproxy/haproxy.initd b/unstable/haproxy/haproxy.initd
new file mode 100644
index 000000000..10466144b
--- /dev/null
+++ b/unstable/haproxy/haproxy.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-proxy/haproxy/files/haproxy.initd,v 1.3 2007/10/27 10:42:32 mrness Exp $
+
+opts="${opts} reload"
+
+CONFFILE=/etc/${SVCNAME}.cfg
+PIDFILE=/var/run/${SVCNAME}.pid
+
+checkconfig() {
+ if [ ! -f "${CONFFILE}" ]; then
+ eerror "${CONFFILE} does not exist!"
+ return 1
+ fi
+ /usr/bin/haproxy -c -f "${CONFFILE}" >/dev/null
+}
+
+depend() {
+ need net
+ use dns logger
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --quiet \
+ --exec /usr/bin/haproxy \
+ -- -D -p "${PIDFILE}" -f "${CONFFILE}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
+ eend ${?}
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ /usr/bin/haproxy -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
+ eend ${?}
+}