summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-04-09 15:06:01 +0000
committerMichael Mason <ms13sp@gmail.com>2009-04-09 15:06:01 +0000
commite34619313cbf14846e7dc181737e5a850a285e14 (patch)
treef3420457f2a3b2370fc56f518762f7b823ca52eb /unstable
parentfddb07087c5496d3ed37debdd0d4b33e3dc9b853 (diff)
downloadaports-e34619313cbf14846e7dc181737e5a850a285e14.tar.bz2
aports-e34619313cbf14846e7dc181737e5a850a285e14.tar.xz
unstable/ucarp moved to testing/ucarp
Diffstat (limited to 'unstable')
-rw-r--r--unstable/ucarp/APKBUILD33
-rw-r--r--unstable/ucarp/ucarp.confd13
-rwxr-xr-xunstable/ucarp/ucarp.initd63
3 files changed, 0 insertions, 109 deletions
diff --git a/unstable/ucarp/APKBUILD b/unstable/ucarp/APKBUILD
deleted file mode 100644
index ed35064f1..000000000
--- a/unstable/ucarp/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor:
-# Maintainer:
-pkgname=ucarp
-pkgver=1.5
-pkgrel=0
-pkgdesc="Share common IP and do fail over"
-url="http://www.ucarp.org"
-license="GPL"
-depends="uclibc libpcap"
-makedepends="libpcap-dev"
-install=
-subpackages=""
-source="http://download.pureftpd.org/pub/ucarp/$pkgname-$pkgver.tar.gz
- ucarp.initd
- ucarp.confd"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
- make DESTDIR="$pkgdir" install
-
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="ba585233e73f0dbce80427d04f431048 ucarp-1.5.tar.gz
-e8f1e2fd144797524025343603dbe2b8 ucarp.initd
-bf914f6ce4fe4fea33a45d4d5b2c1fff ucarp.confd"
diff --git a/unstable/ucarp/ucarp.confd b/unstable/ucarp/ucarp.confd
deleted file mode 100644
index 824358b43..000000000
--- a/unstable/ucarp/ucarp.confd
+++ /dev/null
@@ -1,13 +0,0 @@
-# Things you can set here
-# REALIP - if not set, will be first addr on iface
-# VHID - Virtual Server ID
-# VIP - The Virtual IP
-# PASSWORD - The password for the carp announcements
-# EXTRA_ARGS - extra arguments
-
-REALIP=
-VHID=2
-VIP=127.0.0.1
-PASSWORD=SecretPassword
-#EXTRA_ARGS="--neutral --advbase=3"
-
diff --git a/unstable/ucarp/ucarp.initd b/unstable/ucarp/ucarp.initd
deleted file mode 100755
index d03329fcb..000000000
--- a/unstable/ucarp/ucarp.initd
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-
-# A simple script to start and stop a ucarp instance
-DAEMON=/usr/sbin/ucarp
-
-IFACE="${SVCNAME#*.}"
-if [ -n "$IFACE" ] && [ "${SVCNAME}" != "ucarp" ]; then
- UP="/etc/ucarp/vip-up-$IFACE.sh"
- DOWN="/etc/ucarp/vip-down-$IFACE.sh"
- . /etc/conf.d/ucarp.$IFACE
-else
- UP="/etc/ucarp/vip-up.sh"
- DOWN="/etc/ucarp/vip-down.sh"
-fi
-
-
-# Get the primary ip address for a given interface
-get_first_ip() {
- local foo=$( ip addr show $1 )
- [ $? != 0 ] && foo=""
- echo $( echo "$foo" | grep "inet " | head -n1 | \
- sed "s+^.*inet ++g; s+/.*$++g" )
-}
-
-if [ -z "$REALIP" ]; then
- REALIP=$( get_first_ip $IFACE )
-fi
-
-start () {
- ebegin "Starting ucarp $IFACE"
- start-stop-daemon --start --exec $DAEMON \
- --background -m -p /var/run/ucarp-$IFACE.pid -- \
- -i $IFACE -s $REALIP -v $VHID -p $PASSWORD -a $VIP \
- -u $UP -d $DOWN $EXTRA_ARGS -z
- eend $?
-}
-
-status () {
- ebegin "ucarp $IFACE is ..."
- PIDS=$( pidof $( basename $DAEMON ))
- PID=$( cat /var/run/ucarp-$IFACE.pid 2>/dev/null )
- [ -n "$PID" ] && OK=$( echo "$PIDS" | grep "$PID" )
- if [ -n "$OK" ]; then
- echo "running"
- exit 0
- else
- echo "not running"
- exit 1
- fi
-}
-
-stop () {
- ebegin "Shuting down ucarp $IFACE"
- start-stop-daemon --stop --exec $DAEMON \
- -p /var/run/ucarp-$IFACE.pid
- [ $? -eq 0 ] && rm /var/run/ucarp-$IFACE.pid
- eend $?
-}
-