summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/lua-sql-postgres/APKBUILD (renamed from main/luasql-postgres/APKBUILD)7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/luasql-postgres/APKBUILD b/main/lua-sql-postgres/APKBUILD
index 7c36717f0..08eb9d966 100644
--- a/main/luasql-postgres/APKBUILD
+++ b/main/lua-sql-postgres/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=luasql-postgres
+pkgname=lua-sql-postgres
pkgver=2.1.1
pkgrel=1
pkgdesc="PostgreSQL driver for LuaSQL"
@@ -11,10 +11,15 @@ makedepends="lua-dev postgresql-dev"
install=
subpackages=
source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
+replaces=luasql-postgres
build() {
cd "$srcdir/luasql-$pkgver"
make CFLAGS="$CFLAGS" T=postgres DRIVER_LIBS="-lpq" || return 1
+}
+
+package() {
+ cd "$srcdir/luasql-$pkgver"
install -D src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql/postgres.so
}