summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/freeswitch/APKBUILD8
-rwxr-xr-xmain/freeswitch/freeswitch.initd71
-rw-r--r--main/geh/APKBUILD (renamed from testing/geh/APKBUILD)0
-rw-r--r--main/libelf/APKBUILD (renamed from testing/libelf/APKBUILD)0
-rw-r--r--main/ltrace/APKBUILD (renamed from testing/ltrace/APKBUILD)0
-rw-r--r--main/nagios/APKBUILD (renamed from testing/nagios/APKBUILD)4
-rw-r--r--main/nagios/lighttpd-nagios.conf (renamed from testing/nagios/lighttpd-nagios.conf)0
-rw-r--r--main/nagios/nagios.confd (renamed from testing/nagios/nagios.confd)0
-rw-r--r--main/nagios/nagios.initd (renamed from testing/nagios/nagios.initd)0
9 files changed, 42 insertions, 41 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 860ec0ffe..6560ffe10 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=6
+pkgrel=7
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
@@ -14,8 +14,6 @@ source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
modules.conf
freeswitch.confd
freeswitch.initd
- freeswitch.post-install
- freeswitch.pre-install
"
build() {
@@ -56,6 +54,4 @@ package(){
md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
c05f2356be159e99b3845f5260a33599 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-a15f739b6f4f2c1685ab9f8831d30ca6 freeswitch.initd
-107c52398ff88275006b8223ee0b4907 freeswitch.post-install
-25945ad43b7dd988f37bf6f2603e22be freeswitch.pre-install"
+6973e15d72e5876152b160bd9e8d282b freeswitch.initd"
diff --git a/main/freeswitch/freeswitch.initd b/main/freeswitch/freeswitch.initd
index 0538fff56..91df7e2ac 100755
--- a/main/freeswitch/freeswitch.initd
+++ b/main/freeswitch/freeswitch.initd
@@ -4,55 +4,60 @@
# $Header: $
depend() {
- need net
+ need net
}
opts="reload"
+pidfile=/var/run/freeswitch/freeswitch.pid
start() {
- local OPTS
-
- [ -n "${FREESWITCH_USER}" ] && \
- OPTS="${OPTS} -u ${FREESWITCH_USER}"
-
- [ -n "${FREESWITCH_GROUP}" ] && \
- OPTS="${OPTS} -g ${FREESWITCH_GROUP}"
-
- [ -n "${FREESWITCH_OPTS}" ] && \
- OPTS="${OPTS} ${FREESWITCH_OPTS}"
-
- ebegin "Starting Freeswitch"
- limits
- start-stop-daemon --start --quiet --exec /usr/bin/freeswitch \
- -- -nc -conf /etc/freeswitch -log /var/log/freeswitch \
- -run /var/run/freeswitch -db /var/lib/freeswitch/db \
- -htdocs /usr/share/freeswitch/htdocs \
- -scripts /usr/share/freeswitch/scripts ${OPTS}
- eend $?
+ local OPTS
+
+ [ -n "${FREESWITCH_USER}" ] && \
+ OPTS="${OPTS} -u ${FREESWITCH_USER}"
+
+ [ -n "${FREESWITCH_GROUP}" ] && \
+ OPTS="${OPTS} -g ${FREESWITCH_GROUP}"
+
+ [ -n "${FREESWITCH_OPTS}" ] && \
+ OPTS="${OPTS} ${FREESWITCH_OPTS}"
+
+ ebegin "Starting Freeswitch"
+ limits
+ start-stop-daemon --start --quiet --exec /usr/bin/freeswitch \
+ -- \
+ -nc -conf /etc/freeswitch -log /var/log/freeswitch \
+ -run /var/run/freeswitch -db /var/lib/freeswitch/db \
+ -htdocs /usr/share/freeswitch/htdocs \
+ -scripts /usr/share/freeswitch/scripts ${OPTS}
+ eend $?
}
# Recomended ULIMIT settings
# http://tinyurl.com/2dr467l (i,q,u,x not suppoted)
limits() {
- ulimit -c unlimited
- ulimit -d unlimited
- ulimit -f unlimited
- ulimit -n 999999
- ulimit -v unlimited
- ulimit -s 244
- ulimit -l unlimited
+ ulimit -c unlimited
+ ulimit -d unlimited
+ ulimit -f unlimited
+ ulimit -n 999999
+ ulimit -v unlimited
+ ulimit -s 244
+ ulimit -l unlimited
}
stop() {
- ebegin "Stopping Freeswitch"
- /usr/bin/freeswitch -stop
- eend $?
+ ebegin "Stopping Freeswitch"
+ start-stop-daemon --quiet --stop \
+ --pidfile $pidfile \
+ --retry 10 \
+ --exec /usr/bin/freeswitch
+ eend $?
}
reload() {
- start-stop-daemon --stop --signal 1 --quiet --pidfile \
- /var/run/freeswitch.pid --name freeswitch
- return 0
+ start-stop-daemon --stop --signal 1 --quiet \
+ --pidfile $pidfile --name freeswitch
+ return 0
}
diff --git a/testing/geh/APKBUILD b/main/geh/APKBUILD
index 4f768bdaa..4f768bdaa 100644
--- a/testing/geh/APKBUILD
+++ b/main/geh/APKBUILD
diff --git a/testing/libelf/APKBUILD b/main/libelf/APKBUILD
index 88a52258b..88a52258b 100644
--- a/testing/libelf/APKBUILD
+++ b/main/libelf/APKBUILD
diff --git a/testing/ltrace/APKBUILD b/main/ltrace/APKBUILD
index 145c2a545..145c2a545 100644
--- a/testing/ltrace/APKBUILD
+++ b/main/ltrace/APKBUILD
diff --git a/testing/nagios/APKBUILD b/main/nagios/APKBUILD
index 1bde07a88..37ac05db4 100644
--- a/testing/nagios/APKBUILD
+++ b/main/nagios/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=nagios
pkgver=3.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Popular monitoring tool"
url="http://www.nagios.org/"
license="GPL-2"
@@ -50,7 +50,7 @@ web() {
#depends="php lighttpd"
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/share "$subpkgdir"/usr/
- install -m644 -D "$srcdir"/lighttpd-nagios.conf "$subpkgdir"/etc/lighttpd-nagios.conf
+ install -m644 -D "$srcdir"/lighttpd-nagios.conf "$subpkgdir"/etc/lighttpd/nagios.conf
}
md5sums="d4655ee8c95c9679fd4fd53dac34bbe3 nagios-3.2.1.tar.gz
diff --git a/testing/nagios/lighttpd-nagios.conf b/main/nagios/lighttpd-nagios.conf
index cb7081d84..cb7081d84 100644
--- a/testing/nagios/lighttpd-nagios.conf
+++ b/main/nagios/lighttpd-nagios.conf
diff --git a/testing/nagios/nagios.confd b/main/nagios/nagios.confd
index 0abb80c6e..0abb80c6e 100644
--- a/testing/nagios/nagios.confd
+++ b/main/nagios/nagios.confd
diff --git a/testing/nagios/nagios.initd b/main/nagios/nagios.initd
index e0b3bcf0c..e0b3bcf0c 100644
--- a/testing/nagios/nagios.initd
+++ b/main/nagios/nagios.initd