summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/gcc/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 589abeac7..337a368f1 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -7,11 +7,14 @@ _espfver=0.3.6
_uclibc_abiver=0.9.32
if [ "$ALPINE_LIBC" = "eglibc" ]; then
_chost="i686-pc-linux-gnu"
+ _with_arch="i686"
else
_chost="i486-alpine-linux-uclibc"
+ _dynamic_linker="--with-dynamic-linker=ld-uClibc.so.$_uclibc_abiver"
+ _with_arch="i486"
fi
-pkgrel=4
+pkgrel=5
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
@@ -73,10 +76,12 @@ build ()
--enable-tls \
--enable-threads \
--with-arch=i486 \
- --with-dynamic-linker=ld-uClibc.so.$_uclibc_abiver \
+ $_with_arch \
+ $_dynamic_linker \
--with-dynamic-linker-prefix=/lib \
--with-system-zlib \
- --without-system-libunwind
+ --without-system-libunwind
+
make || return 1
}