summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/xfce4-clipman-plugin/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/xfce4-clipman-plugin/APKBUILD b/testing/xfce4-clipman-plugin/APKBUILD
new file mode 100644
index 000000000..f3e348cac
--- /dev/null
+++ b/testing/xfce4-clipman-plugin/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-clipman-plugin
+pkgver=1.2.3
+pkgrel=0
+pkgdesc="Clipboard manager plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends="libxfce4ui-dev xfce4-panel-dev libunique-dev libxtst-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-clipman-plugin/1.2/xfce4-clipman-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-clipman-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --enable-unique \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/xfce4/panel/plugins/*.la
+}
+
+md5sums="61f3be97efa379cb358980c94e14692a xfce4-clipman-plugin-1.2.3.tar.bz2"