summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/shorewall-common/APKBUILD2
-rw-r--r--main/shorewall-common/shorewall-iptables-deprecated.patch22
2 files changed, 24 insertions, 0 deletions
diff --git a/main/shorewall-common/APKBUILD b/main/shorewall-common/APKBUILD
index f243b9548..2577191a5 100644
--- a/main/shorewall-common/APKBUILD
+++ b/main/shorewall-common/APKBUILD
@@ -10,6 +10,7 @@ depends="iptables iproute2"
subpackages="$pkgname-doc"
source="http://www1.shorewall.net/pub/shorewall/4.2/shorewall-$pkgver/shorewall-common-$pkgver.tar.bz2
shorewall-common-ipset.patch
+ shorewall-iptables-deprecated.patch
shorewall.initd
"
@@ -34,4 +35,5 @@ package() {
}
md5sums="4da98c58a00f1cf1d8c31bdb5db40e96 shorewall-common-4.2.11.tar.bz2
3b120e6e040bd7d8fc85cf30dfeb32a0 shorewall-common-ipset.patch
+575c645d8b880f29e483b9a4933ac59d shorewall-iptables-deprecated.patch
71fb6da1f50f5c6e9dd35b60b3629531 shorewall.initd"
diff --git a/main/shorewall-common/shorewall-iptables-deprecated.patch b/main/shorewall-common/shorewall-iptables-deprecated.patch
new file mode 100644
index 000000000..eff0511a0
--- /dev/null
+++ b/main/shorewall-common/shorewall-iptables-deprecated.patch
@@ -0,0 +1,22 @@
+--- ./lib.config.orig
++++ ./lib.config
+@@ -924,6 +924,9 @@
+ +*)
+ echo "-m set $(get_set_flags $1 src)"
+ ;;
++ !*)
++ echo "! -s ${1#!}"
++ ;;
+ *)
+ echo "-s $1"
+ ;;
+@@ -951,6 +954,9 @@
+ ;;
+ +*)
+ echo "-m set $(get_set_flags $1 dst)"
++ ;;
++ !*)
++ echo "! -d ${1#!}"
+ ;;
+ *)
+ echo "-d $1"