summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/ruby/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index a7aabd970..cbbe23984 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=ruby
-pkgver=1.8.7_p299
-_pkgver=1.8.7-p299
-pkgrel=2
+pkgver=1.8.7_p352
+_pkgver=${pkgver/_/-}
+pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
arch="all"
@@ -33,6 +33,9 @@ build() {
# http://bugs.alpinelinux.org/issues/show/1
export CC=gcc
+ # ruby saves path to install. we want use $PATH
+ export INSTALL=install
+
./configure --build=${CHOST:-i486-alpine-linux-uclibc} \
--prefix=/usr \
--sysconfdir=/etc \
@@ -53,4 +56,4 @@ package() {
}
-md5sums="244439a87d75ab24170a9c2b451ce351 ruby-1.8.7-p299.tar.bz2"
+md5sums="0c61ea41d1b1183b219b9afe97f18f52 ruby-1.8.7-p352.tar.bz2"