summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/abuild/0001-buildrepo-set-REPODEST-when-running-abuild.patch25
-rw-r--r--main/abuild/APKBUILD12
2 files changed, 33 insertions, 4 deletions
diff --git a/main/abuild/0001-buildrepo-set-REPODEST-when-running-abuild.patch b/main/abuild/0001-buildrepo-set-REPODEST-when-running-abuild.patch
new file mode 100644
index 000000000..0dbc4a2b7
--- /dev/null
+++ b/main/abuild/0001-buildrepo-set-REPODEST-when-running-abuild.patch
@@ -0,0 +1,25 @@
+From b1b093180f2795c5802f12ee36b6f619e725b0cd Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 22 Feb 2013 09:35:19 +0000
+Subject: [PATCH] buildrepo: set REPODEST when running abuild
+
+fixes regression
+---
+ buildrepo.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/buildrepo.in b/buildrepo.in
+index 23cc61e..1f218cc 100755
+--- a/buildrepo.in
++++ b/buildrepo.in
+@@ -93,6 +93,7 @@ do_build() {
+ cd "$aportsdir/$repo" || return 0
+ local needbuild="$(list_needbuild $repo)"
+
++ export REPODEST="$repodir"
+ # build the postponed packages if any
+ if [ -n "$needbuild" ]; then
+ for i in $needbuild; do
+--
+1.8.1.3
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index d4819ba52..b360f346a 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -3,7 +3,7 @@ pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.14.1
_ver=${pkgver%_git*}
-pkgrel=1
+pkgrel=2
url=http://git.alpinelinux.org/cgit/abuild/
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1
abuildhelper curl libc-utils"
@@ -15,6 +15,7 @@ arch="all"
license=GPL-2
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$_ver.tar.bz2
0001-buildrepo-parse-APKBUILDs-in-subshell.patch
+ 0001-buildrepo-set-REPODEST-when-running-abuild.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -53,8 +54,11 @@ cpan() {
}
md5sums="ec7c8e453d4331ac20c164c263234f02 abuild-2.14.1.tar.bz2
-d44821805530e9e57a4e27f8fe7f2970 0001-buildrepo-parse-APKBUILDs-in-subshell.patch"
+d44821805530e9e57a4e27f8fe7f2970 0001-buildrepo-parse-APKBUILDs-in-subshell.patch
+1b0e56775cace496612afc9e2e233ff9 0001-buildrepo-set-REPODEST-when-running-abuild.patch"
sha256sums="e9ee3df70118f4f5eb6aca00570c8fb8fb5cf79ed08eb653929116384af77c35 abuild-2.14.1.tar.bz2
-d30ff115fe3595c1dbc8efaeb13233527148ac72c966521f04b9c166a5cceee3 0001-buildrepo-parse-APKBUILDs-in-subshell.patch"
+d30ff115fe3595c1dbc8efaeb13233527148ac72c966521f04b9c166a5cceee3 0001-buildrepo-parse-APKBUILDs-in-subshell.patch
+e33d919078c122b426d09bab7a761bb880fee0d36cc23a4de5114e6f3829f235 0001-buildrepo-set-REPODEST-when-running-abuild.patch"
sha512sums="3eb14b4d4a104c459a7689d862e9efc29b0a5585101af25604248ad6453c7538c56bfe59f4250e3c56357db37dbf7c04115338c55a4ac0231bb3a61545a83cdf abuild-2.14.1.tar.bz2
-775f1ae3128b4083b33c162e572ce2ef438385f5a40145e719331feb60e10e6ad4d0d2c9a9c7f639a7bd53bb01d93b6e23de030b2a22916f275fcaa1fd34e043 0001-buildrepo-parse-APKBUILDs-in-subshell.patch"
+775f1ae3128b4083b33c162e572ce2ef438385f5a40145e719331feb60e10e6ad4d0d2c9a9c7f639a7bd53bb01d93b6e23de030b2a22916f275fcaa1fd34e043 0001-buildrepo-parse-APKBUILDs-in-subshell.patch
+caea0aad0efbc67b4fe8989d5cc9a07c4d99b4882ec7215fb3c769f2f3f7e0a9ab4ac7f0ebbaced05435a797af03328a146c963b5ade6139a7c8fffad167e1c1 0001-buildrepo-set-REPODEST-when-running-abuild.patch"