summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--Makefile69
-rwxr-xr-xaport.lua244
-rw-r--r--main/abuild/0002-add-fetch-from-source-mirror.patch107
-rw-r--r--main/abuild/0003-add-color-control-command-line-option.patch50
-rw-r--r--main/abuild/APKBUILD6
-rw-r--r--main/chrony/APKBUILD4
-rw-r--r--main/dhcp/APKBUILD2
-rw-r--r--main/dialog/APKBUILD4
-rw-r--r--main/heimdal/APKBUILD2
-rw-r--r--main/libconfig/APKBUILD6
-rw-r--r--main/libxfce4menu/APKBUILD2
-rw-r--r--main/lua-uuid/APKBUILD2
-rw-r--r--main/man-pages/APKBUILD6
-rw-r--r--main/pax-utils/APKBUILD2
-rw-r--r--main/procps/01-fix-install-options-for-busybox.patch65
-rw-r--r--main/procps/APKBUILD11
-rw-r--r--main/snort/APKBUILD6
-rw-r--r--main/uiconv/APKBUILD2
-rwxr-xr-xmakeall.sh8
-rwxr-xr-xrebuild-alpine.sh54
-rw-r--r--testing/mutt/APKBUILD50
22 files changed, 680 insertions, 25 deletions
diff --git a/.gitignore b/.gitignore
index 9ef5555f1..eae900da0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,9 @@
*.apk
*.gz
+*.tgz
*.bz2
+*.tbz2
+*.zip
src
pkg
pkg-*
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000..67eb3daae
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,69 @@
+.PHONY: main testing non-free unstable
+
+rootdir := $(shell pwd)
+
+all: main testing non-free unstable
+
+apkbuilds := $(shell find . -maxdepth 3 -name APKBUILD -print)
+
+all-pkgs := $(sort $(subst ./,,$(patsubst %/,%,$(dir $(apkbuilds)))))
+
+main-pkgs := $(shell ./aport.lua deplist $(rootdir) main)
+
+testing-pkgs := $(shell ./aport.lua deplist $(rootdir) testing)
+
+non-free-pkgs := $(shell ./aport.lua deplist $(rootdir) non-free)
+
+unstable-pkgs := $(shell ./aport.lua deplist $(rootdir) unstable)
+
+main:
+ for p in $(main-pkgs) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+testing:
+ for p in $(testing-pkgs) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+non-free:
+ for p in $(non-free-pkgs) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+unstable:
+ for p in $(unstable-pkgs) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+clean:
+ for p in $(all-pkgs) ; do \
+ cd $(rootdir)/$$p; \
+ abuild clean; \
+ abuild cleanpkg; \
+ done
+
+fetch:
+ for p in $(all-pkgs) ; do \
+ cd $(rootdir)/$$p; \
+ abuild fetch; \
+ done
+
+distclean:
+ for p in $(all-pkgs) ; \
+ do \
+ cd $(rootdir)/$$p; \
+ abuild clean; \
+ abuild cleanoldpkg; \
+ abuild cleanpkg; \
+ abuild cleancache; \
+ done
+
diff --git a/aport.lua b/aport.lua
new file mode 100755
index 000000000..71113475a
--- /dev/null
+++ b/aport.lua
@@ -0,0 +1,244 @@
+#!/usr/bin/lua
+
+
+-- those should be read from some config file
+aportsdir = "~/aports"
+repos = { "main", "testing" }
+
+
+function split(str)
+ local t = {}
+ if (str == nil) then
+ return nil
+ end
+ for e in string.gmatch(str, "%S+") do
+ table.insert(t, e)
+ end
+ return t
+end
+
+function split_apkbuild(line)
+ local r = {}
+ local dir, pkgname, pkgver, pkgrel, depends, makedepends, subpackages, source = string.match(line, "([^|]*)|([^|]*)|([^|]*)|([^|]*)|([^|]*)|([^|]*)|([^|]*)")
+ r.dir = dir
+ r.pkgname = pkgname
+ r.pkgver = pkgver
+ r.pkgrel = pkgrel
+ r.depends = split(depends)
+ r.makedepends = split(makedepends)
+ r.subpackages = split(subpackages)
+ r.source = split(source)
+ return r
+end
+
+-- parse the APKBUILDs and return a list
+function parse_apkbuilds(dir, repos)
+ local i,v, p
+ local str=""
+ if repos == nil then
+ return
+ end
+ --expand repos
+ for i,v in ipairs(repos) do
+ str = str..dir.."/"..v.."/*/APKBUILD "
+ end
+
+ local p = io.popen([[
+ for i in ]]..str..[[; do
+ pkgname=
+ pkgver=
+ pkgrel=
+ depends=
+ makedepends=
+ subpackages=
+ source=
+ dir="${i%/APKBUILD}"
+ cd "$dir"
+ . ./APKBUILD
+ echo $dir\|$pkgname\|$pkgver\|$pkgrel\|$depends\|$makedepends\|$subpackages\|$source
+ done
+ ]])
+ return function()
+ local line = p:read("*line")
+ if line == nil then
+ p:close()
+ return nil
+ end
+ return split_apkbuild(line)
+ end
+end
+
+function target_packages(pkgdb, pkgname)
+ local i,v
+ local t = {}
+ for i,v in ipairs(pkgdb[pkgname]) do
+ table.insert(t, pkgname.."-"..v.pkgver.."-r"..v.pkgrel..".apk")
+ end
+ return t
+end
+
+function list_depends( pkg, pkgdb )
+ local dl = {}
+ local s
+ if pkg and not pkg.added then
+ pkg.added = true
+
+ if pkg.depends then
+ for i,v in ipairs(pkg.depends) do
+ --print("v = <"..v..">")
+ s = list_depends( pkgdb[v], pkgdb )
+ if #s > 0 then
+ dl[#dl + 1] = s
+ end
+ end
+ end
+ if pkg.makedepends then
+ for i,v in ipairs(pkg.makedepends) do
+ --print("v = {"..v.."}")
+ s = list_depends( pkgdb[v], pkgdb )
+ if #s > 0 then
+ dl[#dl + 1] = s
+ end
+ end
+ end
+ dl[#dl + 1] = pkg.pkgname
+ end
+
+ s = table.concat(dl," ")
+ --print("s = ["..s.."]")
+ return s
+end
+
+function init_apkdb(aportsdir, repos)
+ local pkgdb = {}
+ local revdeps = {}
+ local a
+
+ for a in parse_apkbuilds(aportsdir, repos) do
+ -- io.write(a.pkgname.." "..a.pkgver.."\t"..a.dir.."\n")
+ if pkgdb[a.pkgname] == nil then
+ pkgdb[a.pkgname] = {}
+ end
+ --table.insert(pkgdb[a.pkgname], a)
+ pkgdb[a.pkgname] = a
+ --print("pk "..a.pkgname.." is a "..type(a).." ("..pkgdb[a.pkgname].pkgname..")")
+ -- add subpackages to package db
+ local k,v
+ for k,v in ipairs(a.subpackages) do
+ if pkgdb[v] == nil then
+ pkgdb[v] = {}
+ end
+ --table.insert(pkgdb[v], a)
+ pkgdb[v] = a
+ end
+ -- add to reverse dependencies
+ for k,v in ipairs(a.makedepends) do
+ if revdeps[v] == nil then
+ revdeps[v] = {}
+ end
+ table.insert(revdeps[v], a)
+ end
+ end
+ return pkgdb, revdeps
+end
+
+-- PKGBUILD import
+function split_pkgbuild(line)
+ local r = {}
+ local pkgname, pkgver = string.match(line, "([^|]*)|([^|]*)")
+ r.pkgname = pkgname
+ r.pkgver = pkgver
+ return r
+end
+
+function parse_pkgbuilds(dir, repos)
+ local i,v, p
+ local str=""
+ if repos == nil then
+ return
+ end
+ --expand repos
+ for i,v in ipairs(repos) do
+ str = str..dir.."/"..v.."/*/PKGBUILD "
+ end
+
+ local p = io.popen([[/bin/bash -c '
+ for i in ]]..str..[[; do
+ pkgname=
+ pkgver=
+ source $i
+ echo $pkgname\|$pkgver
+ done
+ ' 2>/dev/null
+ ]])
+ return function()
+ local line = p:read("*line")
+ if line == nil then
+ p:close()
+ return nil
+ end
+ return split_pkgbuild(line)
+ end
+end
+
+function init_absdb(dir, repos)
+ local p
+ local db = {}
+ for p in parse_pkgbuilds(dir, repos) do
+ if db[p.pkgname] == nil then
+ db[p.pkgname] = {}
+ end
+ table.insert(db[p.pkgname], p.pkgver)
+ end
+ return db
+end
+
+
+-- Applets -----------------------
+applet = {}
+function applet.revdep(arg)
+ local pkg = arg[2]
+ if pkg == nil then
+ -- usage?
+ return nil
+ end
+ local apkdb, rev = init_apkdb(aportsdir, repos)
+ local _,p
+ for _,p in ipairs(rev[pkg] or {}) do
+ print(p.pkgname)
+ end
+end
+--absdb = init_absdb("/var/abs", { "core", "extra", "community" })
+
+function applet.deplist(arg)
+ local apkdb, rev = init_apkdb(arg[2],{ arg[3] })
+
+ local deplist = {}
+ local nm,pk
+ for nm,pk in pairs(apkdb) do
+ local dl
+ --print("pk "..nm.." is a "..type(pk).." ("..apkdb[nm].pkgname..")")
+ --deplist[#deplist + 1] = "***"
+ dl = list_depends(pk,apkdb)
+ -- print("deplist for "..nm..": "..deplist)
+ if #dl > 0 then
+ deplist[#deplist + 1] = dl
+ end
+ end
+ print(table.concat(deplist," "))
+end
+
+cmd = arg[1]
+
+if cmd == nil then
+ -- usage
+ io.stderr:write( "no command given\n" );
+ return
+end
+
+if type(applet[cmd]) == "function" then
+ applet[cmd](arg)
+else
+ io.stderr:write(cmd..": invalid applet\n")
+end
+
diff --git a/main/abuild/0002-add-fetch-from-source-mirror.patch b/main/abuild/0002-add-fetch-from-source-mirror.patch
new file mode 100644
index 000000000..5cd964852
--- /dev/null
+++ b/main/abuild/0002-add-fetch-from-source-mirror.patch
@@ -0,0 +1,107 @@
+diff -rupN orig/abuild-2.1/abuild.in src/abuild-2.1/abuild.in
+--- orig/abuild-2.1/abuild.in 2009-12-30 04:05:49.000000000 -0500
++++ src/abuild-2.1/abuild.in 2010-04-29 09:21:43.000000000 -0400
+@@ -149,12 +149,11 @@ md5check() {
+
+ uri_fetch() {
+ local uri="$1"
+- local d="${s##*/}" # $(basename $s)
++ local d="${uri##*/}" # $(basename $uri)
+ local opts
+ [ -n "$quiet" ] && opts="-q"
+ [ -f "$SRCDEST/$d" ] && return 0
+
+-
+ # we need GNU wget for this
+ case "$uri" in
+ https://*) opts="--no-check-certificate";;
+@@ -178,12 +177,26 @@ is_remote() {
+ return 1
+ }
+
++# try download from file from mirror first
++uri_fetch_mirror() {
++ local uri="$1"
++ local d="${uri##*/}" # $(basename $uri)
++ if [ -n "$DISTFILES_MIRROR" ]; then
++ if [ -f "$DISTFILES_MIRROR"/$d ] ; then
++ cp "$DISTFILES_MIRROR"/$d .
++ else
++ uri_fetch "$DISTFILES_MIRROR"/$d && return 0
++ fi
++ fi
++ uri_fetch "$uri"
++}
++
+ default_fetch() {
+ local s
+ mkdir -p "$srcdir"
+ for s in $source; do
+ if is_remote "$s"; then
+- uri_fetch "$s" || return 1
++ uri_fetch_mirror "$s" || return 1
+ ln -sf "$SRCDEST/${s##*/}" "$srcdir"/
+ else
+ ln -sf "$startdir/$s" "$srcdir/"
+@@ -308,6 +317,12 @@ build() {
+ :
+ }
+
++# generate a simple tar.gz package of pkgdir
++targz() {
++ cd "$pkgdir" || return 1
++ tar -czf "$PKGDEST"/$pkgname-$pkgver-r$pkgrel.tar.gz *
++}
++
+ get_split_func() {
+ # get the 'func' from "sub-pkg:func"
+ local func=${1##*:}
+@@ -712,8 +727,8 @@ up2date() {
+ depparse_aports() {
+ # lets run this in a subshell since we source all APKBUILD here
+ (
+- aportsdir=$(realpath ${APKBUILD%/APKBUILD}/../..)
+- for i in $aportsdir/*/*/APKBUILD; do
++ aportsdir=$(realpath ${APKBUILD%/APKBUILD}/..)
++ for i in $aportsdir/*/APKBUILD; do
+ pkgname=
+ subpackages=
+ depends=
+@@ -811,7 +826,13 @@ builddeps() {
+
+ uninstall_after=".makedepends-$pkgname $uninstall_after"
+ if [ -n "$install_deps" ] && [ -z "$recursive" ]; then
++ # make a --simluate run first to detect missing deps
++ # apk-tools --virtual is no goot at reporting those.
++ $SUDO apk add --repository "$apkcache" \
++ --wait 30 \
++ --simulate --quiet $deps || return 1
+ $SUDO apk add --repository "$apkcache" \
++ --wait 30 \
+ --virtual .makedepends-$pkgname $deps \
+ && return 0
+ fi
+@@ -834,6 +855,7 @@ builddeps() {
+ cd "$dir" && $0 -k -r apkcache || return 1
+ done
+ $SUDO apk add -u --repository "$apkcache" \
++ --wait 30 \
+ --virtual .makedepends-$pkgname $deps
+ }
+
+@@ -945,12 +967,13 @@ post_add() {
+ post_add $i || return 1
+ fi
+ done
+- $SUDO apk add -u "$pkgf" || die "Failed to install $1"
++ $SUDO apk add --wait 30 -u "$pkgf" || die "Failed to install $1"
+ }
+
+ installdeps() {
+ local deps i
+- sudo apk add --repository "$apkcache" --virtual .makedepends-$pkgname \
++ sudo apk add --wait 30 --repository "$apkcache" \
++ --virtual .makedepends-$pkgname \
+ $makedepends
+ }
+
diff --git a/main/abuild/0003-add-color-control-command-line-option.patch b/main/abuild/0003-add-color-control-command-line-option.patch
new file mode 100644
index 000000000..434f634b9
--- /dev/null
+++ b/main/abuild/0003-add-color-control-command-line-option.patch
@@ -0,0 +1,50 @@
+diff -rupN orig/abuild-2.1/abuild.in src/abuild-2.1/abuild.in
+--- orig/abuild-2.1/abuild.in 2010-04-29 12:34:59.000000000 -0400
++++ src/abuild-2.1/abuild.in 2010-04-29 12:35:56.000000000 -0400
+@@ -25,15 +25,27 @@ FAKEROOT=${FAKEROOT:-"fakeroot"}
+ ABUILD_CONF=${ABUILD_CONF:-"$sysconfdir/abuild.conf"}
+ [ -f "$ABUILD_CONF" ] && . "$ABUILD_CONF"
+
+-
+-#colors
+-if [ -n "$USE_COLORS" ]; then
++default_colors() {
+ NORMAL="\033[1;0m"
+ STRONG="\033[1;1m"
+ RED="\033[1;31m"
+ GREEN="\033[1;32m"
+ YELLOW="\033[1;33m"
+ BLUE="\033[1;34m"
++}
++
++monochrome() {
++ NORMAL=""
++ STRONG=""
++ RED=""
++ GREEN=""
++ YELLOW=""
++ BLUE=""
++}
++
++#colors
++if [ -n "$USE_COLORS" ]; then
++ default_colors
+ fi
+
+
+@@ -1036,12 +1048,14 @@ unset force
+ unset recursive
+-while getopts "dfFhi:kinp:P:qrRs:u" opt; do
++while getopts "cdfFhi:kimnp:P:qrRs:u" opt; do
+ case $opt in
++ 'c') default_colors;;
+ 'd') nodeps=1;;
+ 'f') force=1;;
+ 'F') forceroot=1;;
+ 'h') usage;;
+ 'i') install_after="$install_after $OPTARG";;
+ 'k') keep=1;;
++ 'm') monochrome;;
+ 'n') die "Use newapkbuild to create new aports";;
+ 'p') PKGDEST=$OPTARG;;
+ 'P') REPODEST=$OPTARG;;
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 989c7bebe..8c684d6b9 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -4,9 +4,8 @@ pkgname=abuild
pkgver=2.3
pkgrel=0
url=http://git.alpinelinux.org/cgit/abuild/
-source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
- "
-depends="fakeroot file sudo pax-utils openssl apk-tools"
+source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2"
+depends="fakeroot file sudo pax-utils apk-tools"
makedepends="openssl-dev pkgconfig"
license=GPL-2
@@ -20,5 +19,4 @@ package() {
make install DESTDIR="$pkgdir"
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-
md5sums="7c738e0018202160366b8329ec693502 abuild-2.3.tar.bz2"
diff --git a/main/chrony/APKBUILD b/main/chrony/APKBUILD
index b83a0e853..cc0696605 100644
--- a/main/chrony/APKBUILD
+++ b/main/chrony/APKBUILD
@@ -3,12 +3,12 @@ pkgname=chrony
pkgver=1.23
pkgrel=6
pkgdesc="NTP client and server programs"
-url="http://chrony.sunsite.dk/"
+url="http://chrony.tuxfamily.org/"
license="GPL-2"
depends="logrotate"
makedepends="texinfo"
subpackages="$pkgname-doc"
-source="http://www.sfr-fresh.com/linux/misc/chrony-$pkgver.tar.gz
+source="http://download.tuxfamily.org/chrony/$pkgname-$pkgver.tar.gz
$pkgname-1.20-conf.c-gentoo.diff
$pkgname-1.20-chrony.conf.example-gentoo.diff
$pkgname-1.21-makefile.diff
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index 1c334c80e..5b3c7d63d 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -10,7 +10,7 @@ depends=
makedepends=
install="dhcp.pre-install dhcp.post-install dhcp.pre-upgrade dhcp.post-upgrade"
subpackages="$pkgname-doc $pkgname-dev dhclient dhcrelay"
-source="http://ftp.isc.org/isc/dhcp/$pkgname-$_realver.tar.gz
+source="http://ftp.isc.org/isc/dhcp/dhcp-4.1-history/$pkgname-$_realver.tar.gz
linux_ipv6_discover.patch
dhcp-3.0-fix-perms.patch
dhcrelay.initd
diff --git a/main/dialog/APKBUILD b/main/dialog/APKBUILD
index 5c6703dc9..b17527f69 100644
--- a/main/dialog/APKBUILD
+++ b/main/dialog/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dialog
-pkgver=1.1.20080819
+pkgver=1.1.20100119
_ver=${pkgver%.*}-${pkgver##*.}
pkgrel=1
pkgdesc="A script-interpreter which provides a set of curses"
@@ -27,4 +27,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="3caebd641a9f337b980becb4444336c5 dialog.tar.gz"
+md5sums="3d62219658fdddf3c6247fb45831a5d0 dialog.tar.gz"
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index cb867c72a..deab8f868 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -12,7 +12,7 @@ makedepends="gawk readline-dev e2fsprogs-dev>=1.41.9-r2 sqlite-dev autoconf auto
install=
subpackages="$pkgname-doc $pkgname-dev $pkgname-ftp $pkgname-telnet \
$pkgname-su $pkgname-rsh $pkgname-rcp $pkgname-pagsh $pkgname-kf"
-source="http://www.h5l.org/dist/src/$pkgname-$pkgver.tar.gz
+source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
001_all_heimdal-no_libedit.patch
002_all_heimdal-fPIC.patch
003_all_heimdal-rxapps.patch
diff --git a/main/libconfig/APKBUILD b/main/libconfig/APKBUILD
index b566400aa..e4bf50072 100644
--- a/main/libconfig/APKBUILD
+++ b/main/libconfig/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libconfig
-pkgver=1.4.1
-pkgrel=1
+pkgver=1.4.3
+pkgrel=0
pkgdesc="a simple library for manipulating structured configuration files"
url="http://www.hyperrealm.com/libconfig/"
license='LGPL'
@@ -24,4 +24,4 @@ package() {
make -j1 DESTDIR="$pkgdir/" install
}
-md5sums="7b2885272802b3ace56d3c8b445a4588 libconfig-1.4.1.tar.gz"
+md5sums="295f580a7bc3a03a44d520d6ace55ee6 libconfig-1.4.3.tar.gz"
diff --git a/main/libxfce4menu/APKBUILD b/main/libxfce4menu/APKBUILD
index c07f86599..ad6a5fd14 100644
--- a/main/libxfce4menu/APKBUILD
+++ b/main/libxfce4menu/APKBUILD
@@ -9,7 +9,7 @@ depends=
subpackages="$pkgname-dev $pkgname-doc"
makedepends="libxfce4util-dev intltool pkgconfig gtk+-dev gettext-dev
libiconv-dev"
-source="http://mocha.xfce.org/archive/xfce-$pkgver/src/$pkgname-$pkgver.tar.bz2"
+source="http://i386.miwibox.org/distfiles/xfce4/$pkgname-$pkgver.tar.bz2"
build ()
{
diff --git a/main/lua-uuid/APKBUILD b/main/lua-uuid/APKBUILD
index 82f00bf3a..6e760893c 100644
--- a/main/lua-uuid/APKBUILD
+++ b/main/lua-uuid/APKBUILD
@@ -28,4 +28,4 @@ package() {
install -Dm755 uuid.so "$pkgdir"/usr/lib/lua/5.1/uuid.so
}
-md5sums="75f2e8c808c0fb375d9ec5255fd5d4de luuid.tar.gz"
+md5sums="e5bd7c2cf563ac4192b793934f545f49 luuid.tar.gz"
diff --git a/main/man-pages/APKBUILD b/main/man-pages/APKBUILD
index a827b0a79..78336bd56 100644
--- a/main/man-pages/APKBUILD
+++ b/main/man-pages/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=man-pages
-pkgver=3.23
+pkgver=3.24
_posixver=2003-a
-pkgrel=1
+pkgrel=0
pkgdesc="Linux man pages"
url="http://www.kernel.org/doc/man-pages/"
license="GPL"
@@ -27,5 +27,5 @@ build ()
rm "$pkgdir"/usr/share/man/man3/iconv*
}
-md5sums="4d0263bded9ad02a123ce11114ef76ac man-pages-3.23.tar.gz
+md5sums="083fc666f1f1143157901e96c9810539 man-pages-3.24.tar.gz
7c78aff03c0a6767ba483d34f19e4b09 man-pages-posix-2003-a.tar.bz2"
diff --git a/main/pax-utils/APKBUILD b/main/pax-utils/APKBUILD
index 4a7069bc0..b01ea58cd 100644
--- a/main/pax-utils/APKBUILD
+++ b/main/pax-utils/APKBUILD
@@ -17,4 +17,4 @@ build() {
make DESTDIR="$pkgdir/" install
}
-md5sums="15a6f2ddadedac0ab6cd4b0683b767b9 pax-utils-0.2.tar.bz2"
+md5sums="a2097463fd5a34dd707b2d72d84aea89 pax-utils-0.2.tar.bz2"
diff --git a/main/procps/01-fix-install-options-for-busybox.patch b/main/procps/01-fix-install-options-for-busybox.patch
new file mode 100644
index 000000000..792a78155
--- /dev/null
+++ b/main/procps/01-fix-install-options-for-busybox.patch
@@ -0,0 +1,65 @@
+--- orig/procps-3.2.8/Makefile
++++ src/procps-3.2.8/Makefile
+@@ -27,7 +27,7 @@
+ ldconfig := ldconfig
+ ln_f := ln -f
+ ln_sf := ln -sf
+-install := install -D --owner 0 --group 0
++install := install -D -o 0 -g 0
+
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+ lib64 := lib$(shell [ -d /lib64 ] && echo 64)
+@@ -222,10 +222,10 @@
+ ###### install
+
+ $(BINFILES) : all
+- $(install) --mode a=rx $(notdir $@) $@
++ $(install) -m a=rx $(notdir $@) $@
+
+ $(MANFILES) : all
+- $(install) --mode a=r $(notdir $@) $@
++ $(install) -m a=r $(notdir $@) $@
+
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+ cd $(usr/bin) && $(ln_f) skill snice
+--- orig/procps-3.2.8/proc/module.mk
++++ src/procps-3.2.8/proc/module.mk
+@@ -96,7 +96,7 @@
+ #################### install rules ###########################
+
+ $(lib)$(SOFILE) : proc/$(SONAME)
+- $(install) --mode a=rx $< $@
++ $(install) -m a=rx $< $@
+
+ ifneq ($(SOLINK),$(SOFILE))
+ .PHONY: $(lib)$(SOLINK)
+@@ -115,14 +115,14 @@
+ $(ldconfig)
+
+ $(usr/lib)$(ANAME) : proc/$(ANAME)
+- $(install) --mode a=r $< $@
++ $(install) -m a=r $< $@
+
+ # Junk anyway... supposed to go in /usr/include/$(NAME)
+ #INSTALL += $(addprefix $(include),$(HDRFILES))
+ #
+ #$(addprefix $(include),$(HDRFILES)): $(include)% : proc/%
+ #$(include)% : proc/%
+-# $(install) --mode a=r $< $@
++# $(install) -m a=r $< $@
+
+ ##################################################################
+
+--- orig/procps-3.2.8/ps/module.mk
++++ src/procps-3.2.8/ps/module.mk
+@@ -33,8 +33,8 @@
+
+
+ $(bin)ps: ps/ps
+- $(install) --mode a=rx $< $@
++ $(install) -m a=rx $< $@
+
+ $(man1)ps.1 : ps/ps.1
+- $(install) --mode a=r $< $@
++ $(install) -m a=r $< $@
+ -rm -f $(DESTDIR)/var/catman/cat1/ps.1.gz $(DESTDIR)/var/man/cat1/ps.1.gz
diff --git a/main/procps/APKBUILD b/main/procps/APKBUILD
index 4df2d7219..2a3accd62 100644
--- a/main/procps/APKBUILD
+++ b/main/procps/APKBUILD
@@ -9,7 +9,13 @@ depends=
# needs fancy install
makedepends="ncurses-dev coreutils"
subpackages="$pkgname-dev $pkgname-doc libproc"
-source="http://$pkgname.sourceforge.net/$pkgname-$pkgver.tar.gz"
+source="http://$pkgname.sourceforge.net/$pkgname-$pkgver.tar.gz
+ 01-fix-install-options-for-busybox.patch"
+
+prepare() {
+ cd "$srcdir"
+ patch -p1 -i "$srcdir"/01-fix-install-options-for-busybox.patch || return 1
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -31,4 +37,5 @@ libproc() {
ln -s libproc-$pkgver.so "$subpkgdir"/lib/libproc.so
}
-md5sums="9532714b6846013ca9898984ba4cd7e0 procps-3.2.8.tar.gz"
+md5sums="9532714b6846013ca9898984ba4cd7e0 procps-3.2.8.tar.gz
+2b821e841acd08620789d5ffd19d58e9 01-fix-install-options-for-busybox.patch"
diff --git a/main/snort/APKBUILD b/main/snort/APKBUILD
index f9fc94b41..11010a3ad 100644
--- a/main/snort/APKBUILD
+++ b/main/snort/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=snort
-pkgver=2.8.5.1
-pkgrel=1
+pkgver=2.8.5.3
+pkgrel=0
pkgdesc="An open source network intrusion prevention and detection system"
url="http://www.snort.org/"
license="GPL"
@@ -40,6 +40,6 @@ package() {
install -D -m 644 ../snort.confd "$pkgdir"/etc/conf.d/snort
}
-md5sums="b1abf3a9fa3486720c9a2b5eff920417 snort-2.8.5.1.tar.gz
+md5sums="ef02aaad54746603f2cb3236fe962128 snort-2.8.5.3.tar.gz
ffda56f7c20f5cea1c37c971e0f1d6c9 snort.initd
446f8d2b3435b8a6be738da978670605 snort.confd"
diff --git a/main/uiconv/APKBUILD b/main/uiconv/APKBUILD
index 1e4aac3b4..ec563413d 100644
--- a/main/uiconv/APKBUILD
+++ b/main/uiconv/APKBUILD
@@ -14,4 +14,4 @@ build() {
make DESTDIR="$pkgdir" PREFIX=/usr/uiconv install
}
-md5sums="5cd7f80085324d08cb976fec674cd98d uiconv-0.3.tar.bz2"
+md5sums="de2ce8da53f32bdec578e1f0270fa15d uiconv-0.3.tar.bz2"
diff --git a/makeall.sh b/makeall.sh
new file mode 100755
index 000000000..10966c3fd
--- /dev/null
+++ b/makeall.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+for p in 1 2 3
+do
+ echo "============>>> ERROR: Pass $p <<<============"
+ make main 2>&1 | tee makelog-pass-$p-main.txt | grep ">>> ERROR:"
+ make testing 2>&1 | tee makelog-pass-$p-testing.txt | grep ">>> ERROR:"
+done
diff --git a/rebuild-alpine.sh b/rebuild-alpine.sh
new file mode 100755
index 000000000..f613265ae
--- /dev/null
+++ b/rebuild-alpine.sh
@@ -0,0 +1,54 @@
+rootdir=$(pwd)
+
+distclean () {
+ local allpkgs=$(find $rootdir -maxdepth 3 -name APKBUILD -print | sed -e 's/\/APKBUILD//g' | sort)
+ for p in $allpkgs ; do
+ cd $p
+ abuild clean 2>&1
+ abuild cleanoldpkg 2>&1
+ abuild cleanpkg 2>&1
+ abuild cleancache 2>&1
+ done
+}
+
+build () {
+ local pkgs
+ local maintainer
+ pkgs=$(./aport.lua deplist $rootdir $1)
+ for p in $pkgs ; do
+ echo "Building $p"
+ cd $rootdir/$1/$p
+ abuild -rm > $rootdir/$1_$p.txt 2>&1
+ if [ "$?" = "0" ] ; then
+ rm $rootdir/$1_$p.txt
+ else
+ maintainer=$(grep Maintainer APKBUILD | cut -d " " -f 3-)
+ if [ -z "$maintainer" ] ; then
+ maintainer="default maintainer"
+ fi
+ echo "Package $1/$p failed to build (output in $rootdir/$1_$p.txt)"
+ echo "Package $1/$p failed to build. Notify $maintainer. Output is attached" | email -s "NOT SPAM $p build report" -a $rootdir/$1_$p.txt -n AlpineBuildBot -f build@alpinelinux.org amanison@anselsystems.com
+ fi
+ done
+ cd $rootdir
+}
+
+touch START_OF_BUILD.txt
+
+if [ "$1" != "noclean" ] ; then
+ echo "Removing traces of previous builds"
+ tmp=$(distclean)
+fi
+
+echo "Refresh aports tree"
+git pull
+
+for s in main testing nonfree unstable ; do
+ echo "Building packages in $s"
+ build $s
+done
+
+touch END_OF_BUILD.txt
+
+echo "Done"
+
diff --git a/testing/mutt/APKBUILD b/testing/mutt/APKBUILD
new file mode 100644
index 000000000..e8cfa03fd
--- /dev/null
+++ b/testing/mutt/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Andrew Manison<amanison@anselsystems.com>
+# Maintainer: Andrew Manison<amanison@anselsystems.com>
+pkgname=mutt
+pkgver=1.4.2.3
+pkgrel=0
+pkgdesc="a small but very powerful text-mode email client"
+url="http://www.mutt.org"
+license="GPL"
+depends="openssl ncurses libiconv"
+makedepends="openssl-dev ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="ftp://ftp.mutt.org/$pkgname/$pkgname-$pkgver.tar.gz"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-imap \
+ --enable-pop \
+ --enable-smtp \
+ --with-curses \
+ --with-mailpath=/var/spool/mail \
+ --with-ssl
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="dcb94661827dd090fa813e73e122ea0c mutt-1.4.2.3.tar.gz"