summaryrefslogtreecommitdiffstats
path: root/extra/postfix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/postfix/APKBUILD')
-rw-r--r--extra/postfix/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/extra/postfix/APKBUILD b/extra/postfix/APKBUILD
index 93ad33c94..dc0d0e8c3 100644
--- a/extra/postfix/APKBUILD
+++ b/extra/postfix/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
pkgver=2.5.6
-pkgrel=4
+pkgrel=5
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
license="IPL-1"
@@ -41,6 +41,8 @@ build () {
local ccargs="-DHAS_DLOPEN -DHAS_SHL_LOAD"
local auxlibs="$LDFLAGS -lpthread -lcrypt"
+ ccargs="$ccargs -DDEF_DAEMON_DIR=\\\"/usr/lib/postfix\\\""
+
# pcre
ccargs="$ccargs -DHAS_PCRE"
#auxlibs="$auxlibs -lpcre"
@@ -113,7 +115,7 @@ _mv_dict() {
depends="postfix uclibc $@"
install="postfix-${m}.post-install"
mkdir -p "$subpkgdir"/usr/lib/postfix
- mv "$pkgdir"/usr/libexec/postfix/dict_${m}.so \
+ mv "$pkgdir"/usr/lib/postfix/dict_${m}.so \
"$subpkgdir"/usr/lib/postfix/
}