summaryrefslogtreecommitdiffstats
path: root/extra/shorewall-lite
diff options
context:
space:
mode:
Diffstat (limited to 'extra/shorewall-lite')
-rw-r--r--extra/shorewall-lite/APKBUILD20
-rwxr-xr-xextra/shorewall-lite/shorewall-lite.initd65
2 files changed, 0 insertions, 85 deletions
diff --git a/extra/shorewall-lite/APKBUILD b/extra/shorewall-lite/APKBUILD
deleted file mode 100644
index 9c98a3bfd..000000000
--- a/extra/shorewall-lite/APKBUILD
+++ /dev/null
@@ -1,20 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall-lite
-pkgver=4.2.10
-pkgrel=0
-pkgdesc="An iptables-based firewall whose config is handled by a normal Shorewall"
-url="http://www.shorewall.net/"
-license="GPL-2"
-depends="iptables iproute2"
-#subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/4.2/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2
- $pkgname.initd
- "
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- PREFIX="$pkgdir" ./install.sh || return 1
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-md5sums="ef5958819ba18801bacfe20e67184f2a shorewall-lite-4.2.10.tar.bz2
-17a37c934aeb601ce288f77000253e1e shorewall-lite.initd"
diff --git a/extra/shorewall-lite/shorewall-lite.initd b/extra/shorewall-lite/shorewall-lite.initd
deleted file mode 100755
index d2537e8a1..000000000
--- a/extra/shorewall-lite/shorewall-lite.initd
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/files/shorewall-lite,v 1.1 2007/05/20 22:32:36 mjolnir Exp $
-
-opts="start stop restart clear reset refresh"
-
-depend() {
- need net
- provide firewall
- after ulogd
-}
-
-start() {
- ebegin "Starting firewall"
- /sbin/shorewall-lite -f start 1>/dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping firewall"
- /sbin/shorewall-lite stop 1>/dev/null
- eend $?
-}
-
-restart() {
- # shorewall comes with its own control script that includes a
- # restart function, so refrain from calling svc_stop/svc_start
- # here. Note that this comment is required to fix bug 55576;
- # runscript.sh greps this script... (09 Jul 2004 agriffis)
- ebegin "Restarting firewall"
- if [ -f /var/lib/shorewall-lite/restore ] ; then
- /sbin/shorewall-lite restore
- else
- /sbin/shorewall-lite restart 1>/dev/null
- fi
- eend $?
-}
-
-clear() {
- # clear will remove all the rules and bring the system to an unfirewalled
- # state. (21 Nov 2004 eldad)
-
- ebegin "Clearing all firewall rules and setting policy to ACCEPT"
- /sbin/shorewall-lite clear
- eend $?
-}
-
-reset() {
- # reset the packet and byte counters in the firewall
-
- ebegin "Resetting the packet and byte counters in the firewall"
- /sbin/shorewall-lite reset
- eend $?
-}
-
-refresh() {
- # refresh the rules involving the broadcast addresses of firewall
- # interfaces, the black list, traffic control rules and
- # ECN control rules
-
- ebegin "Refreshing firewall rules"
- /sbin/shorewall-lite refresh
- eend $?
-}