summaryrefslogtreecommitdiffstats
path: root/main/apk-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/apk-tools/APKBUILD')
-rw-r--r--main/apk-tools/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 2c96805b4..90cff68dc 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
+ apk-tools-static.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -21,6 +22,9 @@ prepare() {
*.patch) patch -p1 -i "$srcdir"/$i || return 1
esac
done
+ # the patch includes a symlink
+ rm -f src/apk-static.c
+ ln -s apk.c src/apk-static.c
}
build() {
@@ -49,4 +53,5 @@ static() {
}
md5sums="7f9234ab210557b064d7bd9b42833f0a apk-tools-2.0.5.tar.bz2
-f63d483b724e8e9344ce8cb965d5ed22 0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch"
+f63d483b724e8e9344ce8cb965d5ed22 0001-Makefile-do-not-require-lua-pkgconfig-unless-you-int.patch
+3c1f21719a6c4aba51333cf0d88c5600 apk-tools-static.patch"