summaryrefslogtreecommitdiffstats
path: root/main/aspell-en
diff options
context:
space:
mode:
Diffstat (limited to 'main/aspell-en')
-rw-r--r--main/aspell-en/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/aspell-en/APKBUILD b/main/aspell-en/APKBUILD
new file mode 100644
index 000000000..8963220cc
--- /dev/null
+++ b/main/aspell-en/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=aspell-en
+pkgver=6.0
+pkgrel=0
+pkgdesc="English dictionary for aspell"
+url="http://aspell.net/"
+license="custom"
+depends="aspell"
+makedepends="aspell-dev"
+source="ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-$pkgver-0.tar.bz2"
+
+_builddir="$srcdir"/aspell6-en-$pkgver-0
+build () {
+ cd "$_builddir"
+ ./configure || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 Copyright \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+}
+
+md5sums="16449e0a266e1ecc526b2f3cd39d4bc2 aspell6-en-6.0-0.tar.bz2"