summaryrefslogtreecommitdiffstats
path: root/main/gnome-bluetooth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/gnome-bluetooth/APKBUILD')
-rw-r--r--main/gnome-bluetooth/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/main/gnome-bluetooth/APKBUILD b/main/gnome-bluetooth/APKBUILD
new file mode 100644
index 000000000..b8b78abb4
--- /dev/null
+++ b/main/gnome-bluetooth/APKBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-bluetooth
+pkgver=2.32.0
+pkgrel=1
+pkgdesc="The GNOME Bluetooth Subsystem"
+url="http://live.gnome.org/GnomeBluetooth"
+arch="all"
+license="GPL LGPL"
+depends="hicolor-icon-theme obexd-client obex-data-server"
+makedepends="intltool py-gtk gobject-introspection libunique-dev libnotify-dev
+ libxi-dev libxslt py-libxml2 gnome-doc-utils"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.bz2
+ nogeoclue.patch
+ 61-gnome-bluetooth-rfkill.rules"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-nautilus-sendto \
+ --disable-schemas-compile \
+ --disable-introspection \
+ --disable-scrollkeeper \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
+ "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
+}
+
+md5sums="f129686fe46c4c98eb70a0cc85d59cae gnome-bluetooth-2.32.0.tar.bz2
+5ed6f59d02b45573a08155fca8f0d300 nogeoclue.patch
+9fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules"