summaryrefslogtreecommitdiffstats
path: root/main/pam-pgsql/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pam-pgsql/APKBUILD')
-rw-r--r--main/pam-pgsql/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/pam-pgsql/APKBUILD b/main/pam-pgsql/APKBUILD
new file mode 100644
index 000000000..a085bf5ae
--- /dev/null
+++ b/main/pam-pgsql/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pam-pgsql
+pkgver=0.7.3.1
+pkgrel=2
+pkgdesc="PAM module to authenticate using a PostgreSQL database"
+url="http://sourceforge.net/projects/pam-pgsql/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev linux-pam-dev postgresql-dev libgcrypt-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/pam-pgsql/pam-pgsql/0.7/pam-pgsql-$pkgver.tar.gz
+ CVE-2013-0191.patch"
+
+_builddir="$srcdir"/pam-pgsql-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la "$pkgdir"/usr/lib/security/*.la \
+ || return 1
+}
+
+md5sums="16cb40a16ee1f286906a0d5a90254731 pam-pgsql-0.7.3.1.tar.gz
+4a8640edb8eaee4456fa91ad8c22ab7f CVE-2013-0191.patch"