summaryrefslogtreecommitdiffstats
path: root/main/py-twisted-names/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py-twisted-names/APKBUILD')
-rw-r--r--main/py-twisted-names/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/py-twisted-names/APKBUILD b/main/py-twisted-names/APKBUILD
new file mode 100644
index 000000000..bfc31f569
--- /dev/null
+++ b/main/py-twisted-names/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Jeff Bilyk <jbilyk@alpinelinux.org>
+# Maintainer:
+
+pkgname=py-twisted-names
+_pkgname=TwistedNames
+pkgver=12.0.0
+pkgrel=0
+pkgdesc="Python Twisted Names DNS server and resolver library"
+url="http://twistedmatrix.com/trac/wiki/TwistedNames"
+arch="noarch"
+license="MIT"
+depends="py-twisted"
+makedepends="python-dev"
+source="http://twistedmatrix.com/Releases/Names/12.0/$_pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver/
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+
+}
+
+md5sums="1e7b0f1c60d550712245455080f85115 TwistedNames-12.0.0.tar.bz2"