summaryrefslogtreecommitdiffstats
path: root/main/ruby/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/ruby/APKBUILD')
-rw-r--r--main/ruby/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index 1d5cca2d8..b722d325d 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -12,6 +12,7 @@ depends=
makedepends="zlib-dev openssl-dev libiconv-dev gdbm-dev db-dev readline-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="ftp://ftp.ruby-lang.org/pub/ruby/1.8/${pkgname}-${_pkgver}.tar.bz2"
+options="!fhs"
#
# maybe its a good idea to split dep libs to seperate pkg's.
#
@@ -51,7 +52,14 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
-
+ if [ -d "$pkgdir"/usr/local ]; then
+ local f=$(cd "$pkgdir" ; find usr/local -type f)
+ if [ -n "$f" ]; then
+ error "Found files in /usr/local:"
+ echo "$f"
+ return 1
+ fi
+ fi
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}"/COPYING || return 1
}