summaryrefslogtreecommitdiffstats
path: root/main/xulrunner
diff options
context:
space:
mode:
Diffstat (limited to 'main/xulrunner')
-rw-r--r--main/xulrunner/0002-Use-C99-math-isfinite.patch14
-rw-r--r--main/xulrunner/0004-xulrunner-malloc_usable_size.patch34
-rw-r--r--main/xulrunner/APKBUILD10
-rw-r--r--main/xulrunner/uclibc-malloc_usable_size.patch37
4 files changed, 42 insertions, 53 deletions
diff --git a/main/xulrunner/0002-Use-C99-math-isfinite.patch b/main/xulrunner/0002-Use-C99-math-isfinite.patch
index 3d85a6928..03f830bca 100644
--- a/main/xulrunner/0002-Use-C99-math-isfinite.patch
+++ b/main/xulrunner/0002-Use-C99-math-isfinite.patch
@@ -4,23 +4,9 @@ Date: Fri, 25 Nov 2011 08:30:51 +0000
Subject: [PATCH 2/4] Use C99 math isfinite
---
- js/src/ctypes/CTypes.cpp | 2 +-
xpcom/ds/nsMathUtils.h | 6 +++++-
2 files changed, 6 insertions(+), 2 deletions(-)
-diff --git a/js/src/ctypes/CTypes.cpp b/js/src/ctypes/CTypes.cpp
-index 5c0f886..a3b1ae6 100644
---- a/js/src/ctypes/CTypes.cpp
-+++ b/js/src/ctypes/CTypes.cpp
-@@ -467,7 +467,7 @@ static inline bool FloatIsFinite(jsdouble f) {
- #ifdef WIN32
- return _finite(f) != 0;
- #else
-- return finite(f);
-+ return isfinite(f);
- #endif
- }
-
diff --git a/xpcom/ds/nsMathUtils.h b/xpcom/ds/nsMathUtils.h
index 21ffbec..2e80476 100644
--- a/xpcom/ds/nsMathUtils.h
diff --git a/main/xulrunner/0004-xulrunner-malloc_usable_size.patch b/main/xulrunner/0004-xulrunner-malloc_usable_size.patch
deleted file mode 100644
index 986b183ec..000000000
--- a/main/xulrunner/0004-xulrunner-malloc_usable_size.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Timo Teräs <timo.teras@iki.fi>
-
-malloc_usable_size is not defined on uclibc, so workaround
-that in jemalloc. Fix mozalloc linking.
-
---- mozilla-release-old/memory/jemalloc/jemalloc.h
-+++ mozilla-release/memory/jemalloc/jemalloc.h
-@@ -75,8 +75,12 @@
- /* Linux has memalign and malloc_usable_size */
- #if !defined(MOZ_MEMORY_LINUX)
- void *memalign(size_t alignment, size_t size);
--size_t malloc_usable_size(const void *ptr);
- #endif /* MOZ_MEMORY_LINUX */
-+
-+#include <features.h>
-+#if defined(__UCLIBC__) || !defined(MOZ_MEMORY_LINUX)
-+size_t malloc_usable_size(const void *ptr);
-+#endif
-
- void jemalloc_stats(jemalloc_stats_t *stats);
-
---- mozilla-release-old/memory/mozalloc/Makefile.in
-+++ mozilla-release/memory/mozalloc/Makefile.in
-@@ -43,6 +43,10 @@
-
- include $(DEPTH)/config/autoconf.mk
-
-+ifdef MOZ_MEMORY
-+SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc)
-+endif
-+
- VISIBILITY_FLAGS=
- STL_FLAGS =
- ifdef _MSC_VER
diff --git a/main/xulrunner/APKBUILD b/main/xulrunner/APKBUILD
index a282831fe..95db8b77d 100644
--- a/main/xulrunner/APKBUILD
+++ b/main/xulrunner/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xulrunner
-pkgver=13.0.1
+pkgver=14.0.1
_ffoxver=$pkgver
pkgrel=0
pkgdesc="runtime environment for xul-based applications"
@@ -48,7 +48,7 @@ source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
mozconfig
0002-Use-C99-math-isfinite.patch
0003-xulrunner-jemalloc-aslr.patch
- 0004-xulrunner-malloc_usable_size.patch
+ uclibc-malloc_usable_size.patch
cairo.patch
"
@@ -104,9 +104,9 @@ dev() {
mv "${pkgdir}"/usr/include "${subpkgdir}"/usr/include
}
-md5sums="82deadb501c7fc0e9fa6b025f51f05a1 firefox-13.0.1.source.tar.bz2
+md5sums="c2f884f0f6c41c65cf20f678a1ee7191 firefox-14.0.1.source.tar.bz2
b0f7d491bc800b69ec718667a4b08acb mozconfig
-1867db217d10722675c88b655db8c2d7 0002-Use-C99-math-isfinite.patch
+f43c1f0ae57aa8289b130c6de8caf3ce 0002-Use-C99-math-isfinite.patch
7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
-d12e0636e1f9877ef2d1df45d5834c87 0004-xulrunner-malloc_usable_size.patch
+48b7d0404b45b15b8ae4a7d08ac95db3 uclibc-malloc_usable_size.patch
6a3942d96c7ce3c63251761cc12c8349 cairo.patch"
diff --git a/main/xulrunner/uclibc-malloc_usable_size.patch b/main/xulrunner/uclibc-malloc_usable_size.patch
new file mode 100644
index 000000000..b198e2cc5
--- /dev/null
+++ b/main/xulrunner/uclibc-malloc_usable_size.patch
@@ -0,0 +1,37 @@
+--- ./memory/mozalloc/mozalloc.cpp.orig
++++ ./memory/mozalloc/mozalloc.cpp
+@@ -63,7 +63,7 @@
+ #include "mozilla/mozalloc_oom.h" // for mozalloc_handle_oom
+
+ /* Windows doesn't have malloc_usable_size, but jemalloc has */
+-#if defined(MOZ_MEMORY_WINDOWS)
++#if defined(MOZ_MEMORY_WINDOWS) || defined(__UCLIBC__)
+ extern "C" size_t malloc_usable_size(const void *ptr);
+ #endif
+
+@@ -243,10 +243,10 @@
+
+ #if defined(XP_MACOSX)
+ return malloc_size(ptr);
+-#elif defined(MOZ_MEMORY) || (defined(XP_LINUX) && !defined(ANDROID))
++#elif defined(MOZ_MEMORY) || (defined(XP_LINUX) && !defined(ANDROID) &&!defined(__UCLIBC__))
+ // Android bionic libc doesn't have malloc_usable_size.
+ return malloc_usable_size(ptr);
+-#elif defined(XP_WIN)
++#elif defined(XP_WIN) || defined(__UCLIBC__)
+ return _msize(ptr);
+ #else
+ return 0;
+--- mozilla-release-old/memory/mozalloc/Makefile.in
++++ mozilla-release/memory/mozalloc/Makefile.in
+@@ -43,6 +43,10 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++ifdef MOZ_MEMORY
++SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc)
++endif
++
+ VISIBILITY_FLAGS=
+ STL_FLAGS =
+ ifdef _MSC_VER