summaryrefslogtreecommitdiffstats
path: root/testing/bluez/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bluez/APKBUILD')
-rw-r--r--testing/bluez/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/testing/bluez/APKBUILD b/testing/bluez/APKBUILD
index 32c9ec976..b8a18a350 100644
--- a/testing/bluez/APKBUILD
+++ b/testing/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=4.64
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
license="GPL2"
@@ -9,7 +9,10 @@ depends=
makedepends="dbus-dev gstreamer-dev alsa-lib-dev libusb-dev libnl-dev"
subpackages="$pkgname-dev $pkgname-doc libbluetooth $pkgname-alsa $pkgname-cups
$pkgname-netlink"
-source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
+ bluetooth.initd
+ bluetooth.confd
+ "
_builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -39,6 +42,8 @@ build() {
package() {
cd "$_builddir"
make install DESTDIR="$pkgdir"
+ install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
+ install -Dm644 "$srcdir"/bluetooth.confd "$pkgdir"/etc/conf.d/bluetooth
}
libbluetooth() {
@@ -67,4 +72,6 @@ netlink() {
"$subpkgdir"/usr/lib/bluetooth/plugins
}
-md5sums="d6e60bad937fe72b0bc77e327ee470b0 bluez-4.64.tar.bz2"
+md5sums="d6e60bad937fe72b0bc77e327ee470b0 bluez-4.64.tar.bz2
+66408fb89b05e7ce7e61c4c3c356d2c6 bluetooth.initd
+a159d897a057f4675548327329c4cc22 bluetooth.confd"