summaryrefslogtreecommitdiffstats
path: root/testing/py-cssutils
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-cssutils')
-rw-r--r--testing/py-cssutils/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py-cssutils/APKBUILD b/testing/py-cssutils/APKBUILD
new file mode 100644
index 000000000..36378df85
--- /dev/null
+++ b/testing/py-cssutils/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-cssutils
+_pkgname=cssutils
+pkgver=0.9.9
+pkgrel=0
+pkgdesc="A CSS Cascading Style Sheets library for Python"
+url="http://cthedot.de/cssutils/"
+arch="noarch"
+license="LGPL3"
+depends=""
+depends_dev="python-dev py-setuptools"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/c/$_pkgname/$_pkgname-${pkgver}.zip"
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+package() {
+ cd "$_builddir"
+}
+
+md5sums="5f8ea824cc0e0518b574da20e895be08 cssutils-0.9.9.zip"