summaryrefslogtreecommitdiffstats
path: root/testing/py-logilab-astng
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-logilab-astng')
-rw-r--r--testing/py-logilab-astng/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py-logilab-astng/APKBUILD b/testing/py-logilab-astng/APKBUILD
new file mode 100644
index 000000000..0a8a78882
--- /dev/null
+++ b/testing/py-logilab-astng/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-logilab-astng
+_realname=logilab-astng
+pkgver=0.21.1
+pkgrel=0
+pkgdesc="Rebuild a new abstract syntax tree from Python's ast"
+url="http://pypi.python.org/pypi/logilab-astng"
+arch="noarch"
+license="GPL2+"
+depends="python py-logilab-common"
+depends_dev=""
+makedepends="python-dev py-logilab-common"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/l/"$_realname"/"$_realname"-$pkgver.tar.gz"
+_builddir="$srcdir"/"$_realname"-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ rm -f "$pkgdir"/usr/lib/python2.?/site-packages/logilab/__init__.*
+}
+
+md5sums="f25dd1d92a1b80d07a2f9d5bb4fe9d97 logilab-astng-0.21.1.tar.gz"