summaryrefslogtreecommitdiffstats
path: root/testing/vde2
diff options
context:
space:
mode:
Diffstat (limited to 'testing/vde2')
-rw-r--r--testing/vde2/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/vde2/APKBUILD b/testing/vde2/APKBUILD
new file mode 100644
index 000000000..68600f9c6
--- /dev/null
+++ b/testing/vde2/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Zhou <zhoumichaely@gmail.com>
+pkgname=vde2
+pkgver=2.3.1
+pkgrel=0
+pkgdesc="VDE: Virtual Distributed Ethernet. User mode networking for QEMU, UML, etc."
+url="http://vde.sf.net"
+arch="all"
+license="GPL"
+depends="openssl"
+makedepends="openssl-dev libpcap-dev"
+source="http://downloads.sourceforge.net/project/vde/vde2/2.3.1/vde2-2.3.1.tar.gz
+ "
+subpackages="$pkgname-doc $pkgname-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="c8c2acb92a72f779e0b484b1543a1cc3 vde2-2.3.1.tar.gz"