summaryrefslogtreecommitdiffstats
path: root/unstable/freeswitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unstable/freeswitch/APKBUILD')
-rw-r--r--unstable/freeswitch/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/unstable/freeswitch/APKBUILD b/unstable/freeswitch/APKBUILD
deleted file mode 100644
index 293678c7d..000000000
--- a/unstable/freeswitch/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-pkgname=freeswitch
-pkgver=1.0.4
-pkgrel=0
-pkgdesc="A communications platform written in C from the ground up"
-url="http://www.freeswitch.org"
-license="GPL"
-depends=""
-makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev
- autoconf automake libtool"
-install=
-subpackages="$pkgname-dev"
-source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
- modules.conf
- "
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- cp -f "$srcdir/modules.conf" modules.conf || return 1
-
- # i think our max cmd len is 32768
- # by specifying it here we save our selves from some CPU cycles
- export lt_cv_sys_max_cmd_len=8192
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/freeswitch \
- --with-modinstdir=/usr/lib/freeswitch \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
-
- # check how/when parallel builds are fixed here:
- # http://jira.freeswitch.org/browse/FSBUILD-6
-
- # build the libs and prerequisites in parallel first
- make libs/apr/libapr-1.la \
- libs/apr-util/libaprutil-1.la \
- libs/speex/libspeex/libspeexdsp.la \
- libs/sqlite/libsqlite3.la \
- libs/pcre/libpcre.la \
- libs/srtp/libsrtp.la \
- src/include/switch_version.h
-
- # then the rest should build in parallel too
- make || return 1
- make -j1 DESTDIR="$pkgdir" install
-
- # TODO: make and test init.d scripts
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="86e34bdd8cc027d71772cb0dc51388da freeswitch-1.0.4.tar.gz
-c05f2356be159e99b3845f5260a33599 modules.conf"