summaryrefslogtreecommitdiffstats
path: root/unstable/freeswitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unstable/freeswitch/APKBUILD')
-rw-r--r--unstable/freeswitch/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/unstable/freeswitch/APKBUILD b/unstable/freeswitch/APKBUILD
new file mode 100644
index 000000000..df048f605
--- /dev/null
+++ b/unstable/freeswitch/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=freeswitch
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A communications platform written in C from the ground up"
+url="http://www.freeswitch.org"
+license="GPL"
+depends=""
+makedepends="uclibc++-dev curl-dev unixodbc-dev zlib-dev openssl-dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="http://files.freeswitch.org/freeswitch-1.0.3.tar.gz
+ modules.conf
+ freeswitch-1.0.3-libtool22-2.patch
+ freeswitch-1.0.3-parallel-build.patch
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Appling $i..."
+ patch -p1 < $i || return 1
+ done
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+ autoheader || return 1
+ libtoolize || return 1
+
+ export CXX=g++-uc
+ # i think our max cmd len is 32768
+ # by specifying it here we save our selves from some CPU cycles
+ export lt_cv_sys_max_cmd_len=8192
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/freeswitch \
+ --with-modinstdir=/usr/lib/freeswitch \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ # check how/when parallel builds are fixed here:
+ # http://jira.freeswitch.org/browse/FSBUILD-6
+
+ # build the libs and prerequisites in parallel first
+ make libs/apr/libapr-1.la \
+ libs/apr-util/libaprutil-1.la \
+ libs/speex/libspeex/libspeexdsp.la \
+ libs/sqlite/libsqlite3.la \
+ libs/pcre/libpcre.la \
+ libs/srtp/libsrtp.la \
+ src/include/switch_version.h
+
+ # then the rest should build in parallel too
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+
+ # TODO: make and test init.d scripts
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="9352e159b6067ce15afe50ba45c40df7 freeswitch-1.0.3.tar.gz
+c05f2356be159e99b3845f5260a33599 modules.conf
+c9dc93ce5cf13b4bc9ca620131709671 freeswitch-1.0.3-libtool22-2.patch
+5bd0c33cbd2a0a0ea4c12c0e1083e3a2 freeswitch-1.0.3-parallel-build.patch"