summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
Diffstat (limited to 'unstable')
-rw-r--r--unstable/html2ps/APKBUILD31
-rw-r--r--unstable/html2ps/html2ps-conf.patch11
2 files changed, 42 insertions, 0 deletions
diff --git a/unstable/html2ps/APKBUILD b/unstable/html2ps/APKBUILD
new file mode 100644
index 000000000..d1ce4c2da
--- /dev/null
+++ b/unstable/html2ps/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor:
+# Maintainer:
+pkgname=html2ps
+pkgver=1.0b5
+pkgrel=0
+pkgdesc="Perl version of html2ps"
+url="http://user.it.uu.se/~jan/html2ps.html"
+license="GPL"
+depends="perl wget imagemagick"
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="http://user.it.uu.se/~jan/$pkgname-$pkgver.tar.gz
+ html2ps-conf.patch"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i"
+ patch < $i || return 1
+ done
+ mv install install.sh
+
+ install -m755 -D "$srcdir"/$pkgname-$pkgver/html2ps "$pkgdir"/usr/bin/html2ps
+ install -m644 -D "$srcdir"/$pkgname-$pkgver/sample "$pkgdir"/etc/html2ps.conf
+ install -m644 -D "$srcdir"/$pkgname-$pkgver/html2ps.1 "$pkgdir"/usr/share/man/man1/html2ps.1
+ install -m644 -D "$srcdir"/$pkgname-$pkgver/html2psrc.5 "$pkgdir"/usr/share/man/man5/html2psrc.5
+}
+
+md5sums="0998fefa4c8f9a04c88cfac7a83df629 html2ps-1.0b5.tar.gz
+336a9e908578aeee303660a083b58c03 html2ps-conf.patch"
diff --git a/unstable/html2ps/html2ps-conf.patch b/unstable/html2ps/html2ps-conf.patch
new file mode 100644
index 000000000..e96e1e1e8
--- /dev/null
+++ b/unstable/html2ps/html2ps-conf.patch
@@ -0,0 +1,11 @@
+--- html2ps-1.0b5.orig/html2ps Wed Aug 5 19:54:09 2009
++++ html2ps-1.0b5/html2ps Wed Aug 5 19:54:34 2009
+@@ -26,7 +26,7 @@
+ # Set the name of the global configuration file. See the installation notes
+ # and manual page for more details on configuration files.
+
+-$globrc='/opt/misc/lib/html2ps/html2psrc';
++$globrc='/etc/html2ps.conf';
+ $ug='/opt/misc/lib/html2ps/html2ps.html';
+
+ $conf=<<'EOR';