summaryrefslogtreecommitdiffstats
path: root/APKBUILD.5
diff options
context:
space:
mode:
Diffstat (limited to 'APKBUILD.5')
-rw-r--r--APKBUILD.511
1 files changed, 9 insertions, 2 deletions
diff --git a/APKBUILD.5 b/APKBUILD.5
index 5e6aa0d..fdb2a9f 100644
--- a/APKBUILD.5
+++ b/APKBUILD.5
@@ -515,8 +515,15 @@ An install script must be written in shell and must have a
.Li Dq #!/bin/sh
interpreter declaration as the first line. The
.Cm install
-variable must contain the install scripts needed by the package. The different
-actions available are as follows:
+variable must contain the install scripts needed by the package.
+
+The install script will be run inside the root filesystem where the package is
+being installed. A single argument will be passed to all scripts, which is the
+version of the package being installed. The pre-upgrade and post-upgrade
+scripts will have an additional second argument, which is the old version that
+is currently installed on the system.
+
+The different actions that may have install scripts specified are as follows:
.Bl -tag -width Ds
.It Ic $pkgname.pre-install