aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-23 07:51:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-23 07:51:46 +0000
commit103e83f6a967f4e39553f15d4ff947de877f877d (patch)
treed558b8e6c028d3bcb45ba7399ec4f3426348d9df
parent214228db58b119de7ac104219761415c082f72cb (diff)
downloadaports-103e83f6a967f4e39553f15d4ff947de877f877d.tar.bz2
aports-103e83f6a967f4e39553f15d4ff947de877f877d.tar.xz
testing/py-curl: new aport
A Python interface to libcurl http://pycurl.sourceforge.net/
-rw-r--r--testing/py-curl/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py-curl/APKBUILD b/testing/py-curl/APKBUILD
new file mode 100644
index 0000000000..3100eee0d2
--- /dev/null
+++ b/testing/py-curl/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-curl
+pkgver=7.19.0
+pkgrel=0
+pkgdesc="A Python interface to libcurl"
+url="http://pycurl.sourceforge.net/"
+arch="all"
+license="LGPLv2+ or MIT"
+depends="python"
+depends_dev=""
+makedepends="curl-dev python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://pycurl.sourceforge.net/download/pycurl-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pycurl-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="919d58fe37e69fe87ce4534d8b6a1c7b pycurl-7.19.0.tar.gz"