aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGennady Feldman <gena01@gmail.com>2018-01-10 10:57:23 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-24 08:21:33 +0000
commit1db85a8c0c222cd62f9878d16343139207c5d85e (patch)
tree2df875e5249ef45afbfa7a1cc3dd30ebfa2740cf
parent8b14324d24a1ae2b9746f9b225872acd50a72f92 (diff)
downloadaports-1db85a8c0c222cd62f9878d16343139207c5d85e.tar.bz2
aports-1db85a8c0c222cd62f9878d16343139207c5d85e.tar.xz
main/readline: cleanup APKBUILD, adding inputrc.
-rw-r--r--main/readline/APKBUILD23
-rw-r--r--main/readline/inputrc67
2 files changed, 80 insertions, 10 deletions
diff --git a/main/readline/APKBUILD b/main/readline/APKBUILD
index d825c0c42d..033311bbbd 100644
--- a/main/readline/APKBUILD
+++ b/main/readline/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=readline
pkgver=7.0.003
-pkgrel=0
+pkgrel=1
_myver=${pkgver%.*}
pkgdesc="GNU readline library"
-url="https://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+url="https://tiswww.cwru.edu/php/chet/readline/rltop.html"
arch="all"
options="!check"
license="GPL"
@@ -13,6 +13,7 @@ makedepends_host="ncurses-dev"
subpackages="$pkgname-dev $pkgname-doc libhistory"
source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$_myver.tar.gz
fix-ncurses-underlinking.patch
+ inputrc
"
for _patch in $(seq -w 001 ${pkgver##*.}); do
@@ -27,10 +28,10 @@ prepare() {
cd "$builddir"
for i in $source; do
case ${i%::*} in
- *.diff) msg ${i#*::}; patch -p0 -i "$srcdir"/${i%::*} || return 1;;
+ *.diff) msg ${i#*::}; patch -p0 -i "$srcdir"/${i%::*} ;;
esac
done
- default_prepare || return 1
+ default_prepare
update_config_sub
}
@@ -43,29 +44,31 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--enable-static \
- --enable-shared \
- || return 1
- make || return 1
+ --enable-shared
+ make
}
package() {
- make -C "$builddir" DESTDIR="$pkgdir" install || return 1
+ make -C "$builddir" DESTDIR="$pkgdir" install
# verfy that its not underlinked as upstream designed it
if ! readelf -d "$pkgdir"/usr/lib/libreadline.so | grep 'NEEDED.*ncurses'; then
error "readline needs to be linked against ncurses"
return 1
fi
rmdir "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/etc
+ install -m644 "$srcdir"/inputrc "$pkgdir"/etc/inputrc
}
libhistory() {
pkgdesc="GNU History Library"
- mkdir -p "$subpkgdir"/usr/lib || return 1
- mv "$pkgdir"/usr/lib/$subpkgname.* "$subpkgdir"/usr/lib || return 1
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/$subpkgname.* "$subpkgdir"/usr/lib
}
sha512sums="18243189d39bf0d4c8a76cddcce75243c1bae8824c686e9b6ba352667607e5b10c5feb79372a1093c1c388d821841670702e940df12eae94bcebdeed90047870 readline-7.0.tar.gz
325dcf74e9f463a74fb116cb6f3ff8d9708dbec24b423a778eeda3a5ac4fe6df131e0e99d034053ad356b01502894ecc8facc09160d4c29b2291bd95cff6b635 fix-ncurses-underlinking.patch
+5dbe872e94166aaed7ca2edec5a34ef9b13b254381e252cc6d851877b461579903cbb5b5dc588eabececcf1ebe636f6cb4da406cd01b64757f8c7e7f62e9a276 inputrc
4402186905af8cd42c609d640c2e13b9ad61c7778e5a3fd2c2d9da301f0deab05b04d7836f31527262f44f406517823dbb18cb07f2c73931186c806b494699ec readline70-001.diff
13d1489578508d4d2c3a1618024198a709dbce74a6bbf0f6d7ec67d2419c55bfec9f0ca9de0ed93f129d21d5c3a94307ccdc49408455bbb301c5e3a772b03185 readline70-002.diff
eaf962a1480eb3870519017b81ecc5cef171e4c41fcf8c17da61ccbfd0379ed6bca85c17b03e2207ae4d51509f33fd010294c75f4bd0433a52118015d4160385 readline70-003.diff"
diff --git a/main/readline/inputrc b/main/readline/inputrc
new file mode 100644
index 0000000000..d3da98595c
--- /dev/null
+++ b/main/readline/inputrc
@@ -0,0 +1,67 @@
+# /etc/inputrc - global inputrc for libreadline
+# See readline(3readline) and `info rluserman' for more information.
+
+# Be 8 bit clean.
+set input-meta on
+set output-meta on
+
+# To allow the use of 8bit-characters like the german umlauts, uncomment
+# the line below. However this makes the meta key not work as a meta key,
+# which is annoying to those which don't need to type in 8-bit characters.
+
+# set convert-meta off
+
+# try to enable the application keypad when it is called. Some systems
+# need this to enable the arrow keys.
+# set enable-keypad on
+
+# see /usr/share/doc/bash/inputrc.arrows for other codes of arrow keys
+
+# do not bell on tab-completion
+# set bell-style none
+# set bell-style visible
+
+# some defaults / modifications for the emacs mode
+$if mode=emacs
+
+# allow the use of the Home/End keys
+"\e[1~": beginning-of-line
+"\e[4~": end-of-line
+
+# allow the use of the Delete/Insert keys
+"\e[3~": delete-char
+"\e[2~": quoted-insert
+
+# mappings for "page up" and "page down" to step to the beginning/end
+# of the history
+# "\e[5~": beginning-of-history
+# "\e[6~": end-of-history
+
+# alternate mappings for "page up" and "page down" to search the history
+# "\e[5~": history-search-backward
+# "\e[6~": history-search-forward
+
+# mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
+"\e[1;5C": forward-word
+"\e[1;5D": backward-word
+"\e[5C": forward-word
+"\e[5D": backward-word
+"\e\e[C": forward-word
+"\e\e[D": backward-word
+
+$if term=rxvt
+"\e[7~": beginning-of-line
+"\e[8~": end-of-line
+"\eOc": forward-word
+"\eOd": backward-word
+$endif
+
+# for non RH/Debian xterm, can't hurt for RH/Debian xterm
+# "\eOH": beginning-of-line
+# "\eOF": end-of-line
+
+# for freebsd console
+# "\e[H": beginning-of-line
+# "\e[F": end-of-line
+
+$endif