aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-08-20 20:58:36 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-24 08:45:59 +0000
commit2617aebe4b063767ae360caa649d5f47484b0fad (patch)
tree5f5bbceeaf38ee3e24434fa0addce088a6ac37f8
parent2105b33dfa10b809ca4abab429f3b748cd718729 (diff)
downloadaports-2617aebe4b063767ae360caa649d5f47484b0fad.tar.bz2
aports-2617aebe4b063767ae360caa649d5f47484b0fad.tar.xz
community/ostree: upgrade to 2018.7
-rw-r--r--community/ostree/APKBUILD10
-rw-r--r--community/ostree/fix-format-string.patch31
2 files changed, 4 insertions, 37 deletions
diff --git a/community/ostree/APKBUILD b/community/ostree/APKBUILD
index 1890f5cd9b..e91e209e3e 100644
--- a/community/ostree/APKBUILD
+++ b/community/ostree/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=ostree
-pkgver=2018.6
-pkgrel=1
+pkgver=2018.7
+pkgrel=0
pkgdesc="Operating system and container binary deployment and upgrades"
url="https://github.com/ostreedev/ostree"
arch="all"
@@ -12,7 +12,6 @@ makedepends="bison glib-dev xz-dev libarchive-dev e2fsprogs-dev
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/ostreedev/ostree/releases/download/v$pkgver/libostree-$pkgver.tar.xz
musl-fixes.patch
- fix-format-string.patch
"
options="!check"
builddir="$srcdir/lib$pkgname-$pkgver"
@@ -38,6 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="619ca4987b498f27887fcf48cd10bb1b892ff0c69146dc1a422734d96046f261f16aea052564c9886dc3a0633b5b4cc71764ca68a6a1e5457d677b58d09d6b40 libostree-2018.6.tar.xz
-539f5020f3380e841372f80c60c71c803ccfeffb719f1b83361b75557022c61d9cd29d9cd36929426420644def9de91fd92f5dd6923352f2ae6e1dd4b676de8c musl-fixes.patch
-aa3639edc31aad59d1da4791874967f161ddc1548b30984d90e740cc207c190c85733fb5c74d057aabdc0af128f9dce1a2e1fc2f2144180d7b0bed97e690d735 fix-format-string.patch"
+sha512sums="edb3f1d6dddd801ad18bbbc30a04f01ac269081ea175bb5cdf90589f4ab9355aa3bb2ead3c2f96fc0892e02ddd5e9809cac52dfb5e85808da6954d82bf63957a libostree-2018.7.tar.xz
+539f5020f3380e841372f80c60c71c803ccfeffb719f1b83361b75557022c61d9cd29d9cd36929426420644def9de91fd92f5dd6923352f2ae6e1dd4b676de8c musl-fixes.patch"
diff --git a/community/ostree/fix-format-string.patch b/community/ostree/fix-format-string.patch
deleted file mode 100644
index 3bbbe434d7..0000000000
--- a/community/ostree/fix-format-string.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Without this patch the build fails with the following gcc error:
-
-src/libostree/ostree-repo-commit.c: In function 'write_content_object':
-src/libostree/ostree-repo-commit.c:906:62: error: format '%lu' expects argument of type 'long unsigned int', but argument 3 has type 'guint64 {aka long long unsigned int}' [-Werror=format=]
- return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s more required",
-
-src/libostree/ostree-repo-commit.c: In function 'ostree_repo_prepare_transaction':
-src/libostree/ostree-repo-commit.c:1620:62: error: format '%lu' expects argument of type 'long unsigned int', but argument 3 has type 'guint64 {aka long long unsigned int}' [-Werror=format=]
- return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s available",
-
-diff -upr libostree-2018.6.orig/src/libostree/ostree-repo-commit.c libostree-2018.6/src/libostree/ostree-repo-commit.c
---- libostree-2018.6.orig/src/libostree/ostree-repo-commit.c 2018-06-30 21:51:20.208924241 +0200
-+++ libostree-2018.6/src/libostree/ostree-repo-commit.c 2018-06-30 21:52:12.019151826 +0200
-@@ -903,7 +903,7 @@ write_content_object (OstreeRepo
- return glnx_throw (error, "min-free-space-percent '%u%%' would be exceeded, %s more required",
- self->min_free_space_percent, formatted_required);
- else
-- return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s more required",
-+ return glnx_throw (error, "min-free-space-size %" G_GUINT64_FORMAT "MB would be exceeded, %s more required",
- self->min_free_space_mb, formatted_required);
- }
- /* This is the main bit that needs mutex protection */
-@@ -1617,7 +1617,7 @@ ostree_repo_prepare_transaction (OstreeR
- return glnx_throw (error, "min-free-space-percent '%u%%' would be exceeded, %s available",
- self->min_free_space_percent, formatted_free);
- else
-- return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s available",
-+ return glnx_throw (error, "min-free-space-size %" G_GUINT64_FORMAT "MB would be exceeded, %s available",
- self->min_free_space_mb, formatted_free);
- }
- g_mutex_unlock (&self->txn_lock);