aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 04:16:39 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 04:16:39 +0000
commit36a0a499fd5fdf0d92f522d36559c4be8c4eb514 (patch)
treefc9a20320f3325635fb0b572824e4e37811f0de3
parenta7ff0e3386c78942f5087629c8b5eb07d563f032 (diff)
downloadaports-36a0a499fd5fdf0d92f522d36559c4be8c4eb514.tar.bz2
aports-36a0a499fd5fdf0d92f522d36559c4be8c4eb514.tar.xz
testing/py-shortuuid: new aport
-rw-r--r--testing/py-shortuuid/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-shortuuid/APKBUILD b/testing/py-shortuuid/APKBUILD
new file mode 100644
index 0000000000..d7af5f0f80
--- /dev/null
+++ b/testing/py-shortuuid/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-shortuuid
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="an shortuuid implementation"
+url="https://pypi.python.org/pypi/shortuuid/"
+arch="noarch"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-shortuuid:py2 py3-shortuuid:py3"
+source="https://files.pythonhosted.org/packages/source/s/shortuuid/shortuuid-$pkgver.tar.gz"
+builddir="$srcdir/shortuuid-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="bf0b804281af1a515979a104c22e0c0e5cf99fe55efe6e29bb4b4b0d1d5a78b1e83a2d0262d6c2e2c2745f5ea198153fba80718aabac2955c691e6cb9bd5f4b5 shortuuid-0.5.0.tar.gz"