aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-02 19:59:58 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 07:26:55 +0000
commit7b6129fcc85b29439687d57d6fe32309ed254934 (patch)
tree435d9a66b3a4c58f3b217d8df75c0c26b1c4c713
parenta8e0cc4ca941f3acd2cdb2f4ee65052f354ece36 (diff)
downloadaports-7b6129fcc85b29439687d57d6fe32309ed254934.tar.bz2
aports-7b6129fcc85b29439687d57d6fe32309ed254934.tar.xz
main/scons: upgrade to 3.0.1
-rw-r--r--main/scons/APKBUILD14
-rw-r--r--main/scons/scons-support-python2-syntax.patch107
2 files changed, 6 insertions, 115 deletions
diff --git a/main/scons/APKBUILD b/main/scons/APKBUILD
index 8a7a3a65e8..08f798f09b 100644
--- a/main/scons/APKBUILD
+++ b/main/scons/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=scons
-pkgver=3.0.0
-pkgrel=1
-pkgdesc="scons software construction system"
-url="http://www.scons.org/"
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="Software construction system"
+url="http://www.scons.org"
arch="noarch"
license="MIT"
depends="python3"
makedepends="python2-dev"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- scons-support-python2-syntax.patch"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -28,5 +27,4 @@ check() {
python2 setup.py check
}
-sha512sums="e52c31a21f8aab4bbb684a8770cbcb9eeef042d5c8c86ea2f4beb64ec0c50bc1ca4aa738a2bf92330bd26f8fa9589cb10314dc53defccc2825a5a13b01641b2d scons-3.0.0.tar.gz
-887d4d235cc52251e2d251ed43fe9d89b0c1253ea36b1717f444c8b825bd516c4bc93b49ca35a753335f403f6133940439eeed8f5e6be2572acc6ee67c53d09b scons-support-python2-syntax.patch"
+sha512sums="b7be40ba507366cc678f31b910553cadaf59781c3a91833a34acbd29d9cad0cda38f6753034bf92c3af55d1e0c2f72aba5d81f1ec67205d0345b005d286f7084 scons-3.0.1.tar.gz"
diff --git a/main/scons/scons-support-python2-syntax.patch b/main/scons/scons-support-python2-syntax.patch
deleted file mode 100644
index a013539a6a..0000000000
--- a/main/scons/scons-support-python2-syntax.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From 2e0de3c55f22b3eaa7767b69740b898f3d2f46bf Mon Sep 17 00:00:00 2001
-From: Thomas Berg <merlin66b@gmail.com>
-Date: Wed, 20 Sep 2017 13:24:22 +0200
-Subject: [PATCH] Support python 2 print statements in SConscripts
-
-This fixes a regression introduced in scons-3.0.0, where
-SConscripts containing python 2 print statements would cause
-syntax errors even when executing scons with python 2.7.
-
-This ensures backward compatibility, allowing users to build
-legacy code with scons-3.0.0 without having to patch it.
----
- src/CHANGES.txt | 3 ++
- src/engine/SCons/Script/SConscript.py | 2 --
- test/print_statement.py | 56 +++++++++++++++++++++++++++++++++++
- 3 files changed, 59 insertions(+), 2 deletions(-)
- create mode 100644 test/print_statement.py
-
-diff --git a/src/CHANGES.txt b/src/CHANGES.txt
-index 4b492e6a..0e742ec5 100644
---- a/CHANGES.txt
-+++ b/CHANGES.txt
-@@ -11,6 +11,9 @@ RELEASE VERSION/DATE TO BE FILLED IN LATER
-
- - Whatever John Doe did.
-
-+ From Thomas Berg:
-+ - Fixed a regression in scons-3.0.0 where "from __future__ import print_function" was imposed
-+ on the scope where SConstruct is executed, breaking existing builds using PY 2.7.
-
- RELEASE 3.0.0 - Mon, 18 Sep 2017 08:32:04 -0700
-
-diff --git a/src/engine/SCons/Script/SConscript.py b/src/engine/SCons/Script/SConscript.py
-index 558e28f9..8fea9c4d 100644
---- a/engine/SCons/Script/SConscript.py
-+++ b/engine/SCons/Script/SConscript.py
-@@ -5,8 +5,6 @@
-
- """
-
--from __future__ import print_function
--
- #
- # __COPYRIGHT__
- #
-diff --git a/test/print_statement.py b/test/print_statement.py
-new file mode 100644
-index 00000000..22050593
---- /dev/null
-+++ b/print_statement.py
-@@ -0,0 +1,56 @@
-+#!/usr/bin/env python
-+#
-+# __COPYRIGHT__
-+#
-+# Permission is hereby granted, free of charge, to any person obtaining
-+# a copy of this software and associated documentation files (the
-+# "Software"), to deal in the Software without restriction, including
-+# without limitation the rights to use, copy, modify, merge, publish,
-+# distribute, sublicense, and/or sell copies of the Software, and to
-+# permit persons to whom the Software is furnished to do so, subject to
-+# the following conditions:
-+#
-+# The above copyright notice and this permission notice shall be included
-+# in all copies or substantial portions of the Software.
-+#
-+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
-+# KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
-+# WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-+# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-+# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-+# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-+#
-+
-+__revision__ = "__FILE__ __REVISION__ __DATE__ __DEVELOPER__"
-+
-+import sys
-+import TestSCons
-+
-+test = TestSCons.TestSCons()
-+
-+
-+test.write('SConstruct', """\
-+print('python 3 style statement')
-+Exit(0)
-+""")
-+
-+test.run()
-+
-+test.write('SConstruct', """\
-+print 'python 2 style statement'
-+Exit(0)
-+""")
-+
-+if sys.version_info >= (3,0):
-+ test.skip_test('Python 2 print statement test, skipping on Python 3.\n')
-+else:
-+ test.run()
-+
-+test.pass_test()
-+
-+# Local Variables:
-+# tab-width:4
-+# indent-tabs-mode:nil
-+# End:
-+# vim: set expandtab tabstop=4 shiftwidth=4: