aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-22 14:57:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-22 14:57:54 +0200
commit9c9185a440ae35ea2df447a0ff4f35fd5a001758 (patch)
tree5af0759b0c72eb61278b8cb98e01daefe6b1ab26
parent50d30564ce2aae879a5afd925c9addfb158afade (diff)
downloadaports-9c9185a440ae35ea2df447a0ff4f35fd5a001758.tar.bz2
aports-9c9185a440ae35ea2df447a0ff4f35fd5a001758.tar.xz
testing/llvm4: remove leftover
llvm4 has been already moved into main, this remained here by some mistake.
-rw-r--r--testing/llvm4/APKBUILD202
1 files changed, 0 insertions, 202 deletions
diff --git a/testing/llvm4/APKBUILD b/testing/llvm4/APKBUILD
deleted file mode 100644
index 799aef9fec..0000000000
--- a/testing/llvm4/APKBUILD
+++ /dev/null
@@ -1,202 +0,0 @@
-# Contributor: Travis Tilley <ttilley@gmail.com>
-# Contributor: Mitch Tishmack <mitch.tishmack@gmail.com>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-_pkgname=llvm
-pkgver=4.0.0
-_majorver=${pkgver%%.*}
-pkgname=$_pkgname$_majorver
-pkgrel=1
-pkgdesc="Low Level Virtual Machine compiler system (version $_majorver)"
-arch="all"
-url="http://llvm.org/"
-license="UOI-NCSA"
-depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="binutils-dev chrpath cmake file libffi-dev paxmark python2 zlib-dev"
-subpackages="$pkgname-static $pkgname-libs $pkgname-dev"
-source="http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz
- llvm-fix-build-with-musl-libc.patch
- llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
- cmake-fix-libLLVM-name.patch
- disable-FileSystemTest.CreateDir-perms-assert.patch
- silent-amdgpu-test-failing.patch
- "
-builddir="$srcdir/$_pkgname-$pkgver.src"
-
-# NOTE: It seems that there's no (sane) way how to change includedir, sharedir
-# etc. separately, just the CMAKE_INSTALL_PREFIX. Standard CMake variables and
-# even LLVM-specific variables, that are related to these paths, actually
-# don't work (in llvm 3.7).
-#
-# When building a software that depends on LLVM, utility llvm-config should be
-# used to discover where is LLVM installed. It provides options to print
-# path of bindir, includedir, and libdir separately, but in its source, all
-# these paths are actually hard-coded against INSTALL_PREFIX. We can patch it
-# and move paths manually, but I'm really not sure what it may break...
-#
-# Also note that we should *not* add version suffix to files in llvm bindir!
-# It breaks build system of some software that depends on LLVM, because they
-# don't expect these files to have a sufix.
-#
-# So, we install all the LLVM files into /usr/lib/llvm$_majorver.
-# BTW, Fedora and Debian do the same thing.
-#
-_prefix="usr/lib/llvm$_majorver"
-
-prepare() {
- default_prepare
- cd "$builddir"
-
- # https://bugs.llvm.org//show_bug.cgi?id=31870
- rm test/tools/llvm-symbolizer/print_context.c
-
- mkdir -p "$builddir"/build
-}
-
-build() {
- cd "$builddir"/build
-
- # Auto-detect it by guessing either.
- local ffi_include_dir="$(pkg-config --cflags-only-I libffi | sed 's|^-I||g')"
-
- cmake -G "Unix Makefiles" -Wno-dev \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/$_prefix \
- -DCMAKE_VERBOSE_MAKEFILE=NO \
- -DFFI_INCLUDE_DIR="$ffi_include_dir" \
- -DLLVM_BINUTILS_INCDIR=/usr/include \
- -DLLVM_BUILD_DOCS=OFF \
- -DLLVM_BUILD_EXAMPLES=OFF \
- -DLLVM_BUILD_EXTERNAL_COMPILER_RT=ON \
- -DLLVM_BUILD_LLVM_DYLIB=ON \
- -DLLVM_BUILD_TESTS=ON \
- -DLLVM_DEFAULT_TARGET_TRIPLE="$CBUILD" \
- -DLLVM_DYLIB_EXPORT_ALL=ON \
- -DLLVM_ENABLE_ASSERTIONS=OFF \
- -DLLVM_ENABLE_CXX1Y=ON \
- -DLLVM_ENABLE_FFI=ON \
- -DLLVM_ENABLE_LIBCXX=OFF \
- -DLLVM_ENABLE_PIC=ON \
- -DLLVM_ENABLE_RTTI=ON \
- -DLLVM_ENABLE_SPHINX=OFF \
- -DLLVM_ENABLE_TERMINFO=ON \
- -DLLVM_ENABLE_ZLIB=ON \
- -DLLVM_HOST_TRIPLE="$CHOST" \
- -DLLVM_INCLUDE_EXAMPLES=OFF \
- -DLLVM_LINK_LLVM_DYLIB=ON \
- -DLLVM_TARGETS_TO_BUILD='X86;ARM;AArch64;PowerPC;AMDGPU;NVPTX;Mips;BPF' \
- "$builddir"
-
- make llvm-tblgen
- make
-
- paxmark m \
- bin/llvm-rtdyld \
- bin/lli \
- bin/lli-child-target \
- unittests/ExecutionEngine/MCJIT/MCJITTests \
- unittests/ExecutionEngine/Orc/OrcJITTests \
- unittests/Support/SupportTests
-}
-
-check() {
- cd "$builddir"/build
-
- # ARM has few failures in test suite that we don't care about currently.
- case "$CARCH" in
- arm*) make check-llvm || true;;
- *) make check-llvm;;
- esac
-}
-
-package() {
- cd "$builddir"/build
-
- make DESTDIR="$pkgdir" install
-
- # This tool is needed e.g. for running codegen tests in Rust package.
- install -D -m 755 bin/FileCheck "$pkgdir"/$_prefix/bin/FileCheck
-
- cd "$pkgdir"/$_prefix
-
- # Remove RPATHs.
- file lib/*.so bin/* \
- | awk -F: '$2~/ELF/{print $1}' \
- | xargs -r chrpath -d
-
- # Symlink files in bindir to /usr/bin with version infix/suffix.
- mkdir -p "$pkgdir"/usr/bin
- local name newname path
- for path in bin/*; do
- name=${path##*/}
- case "$name" in
- llvm-*) newname="llvm$_majorver-${name#llvm-}";;
- *) newname="$name$_majorver";;
- esac
- case "$name" in
- FileCheck | obj2yaml | yaml2obj) continue;;
- esac
- ln -s ../lib/llvm$_majorver/bin/$name "$pkgdir"/usr/bin/$newname
- done
-
- # Move /usr/lib/$pkgname/include/ into /usr/include/$pkgname/
- # and symlink it back.
- _mv include/* "$pkgdir"/usr/include/$pkgname/
- rmdir include
- ln -s ../../include/$pkgname include
-
- # Move /usr/lib/$pkgname/lib/cmake/llvm/ into /usr/lib/cmake/$pkgname/
- # and symlink it back.
- _mv lib/cmake/llvm/* "$pkgdir"/usr/lib/cmake/$pkgname/
- rmdir lib/cmake/llvm
- ln -s ../../../cmake/$pkgname lib/cmake/llvm
-}
-
-static() {
- pkgdesc="LLVM $_majorver static libraries"
-
- _mv "$pkgdir"/$_prefix/lib/*.a "$subpkgdir"/$_prefix/lib/
-}
-
-libs() {
- pkgdesc="LLVM $_majorver runtime library"
- local soname="libLLVM-$_majorver.0.so"
- local soname2="libLLVM-$pkgver.so"
-
- mkdir -p "$subpkgdir"
- cd "$subpkgdir"
-
- # libLLVM should be in /usr/lib. This is needed for binaries that are
- # dynamically linked with libLLVM, so they can find it on default path.
- _mv "$pkgdir"/$_prefix/lib/$soname usr/lib/
- ln -s $soname usr/lib/$soname2
-
- # And also symlink it back to the LLVM prefix.
- mkdir -p $_prefix/lib
- ln -s ../../$soname $_prefix/lib/$soname
- ln -s ../../$soname $_prefix/lib/$soname2
-}
-
-dev() {
- default_dev
- cd "$subpkgdir"
-
- _mv "$pkgdir"/$_prefix/lib $_prefix/
- _mv "$pkgdir"/$_prefix/include $_prefix/
-
- _mv "$pkgdir"/$_prefix/bin/FileCheck $_prefix/bin/
- _mv "$pkgdir"/$_prefix/bin/llvm-config $_prefix/bin/
-}
-
-_mv() {
- local dest; for dest; do true; done # get last argument
- mkdir -p "$dest"
- mv $@
-}
-
-sha512sums="cf681f0626ef6d568d951cdc3e143471a1d7715a0ba11e52aa273cf5d8d421e1357ef2645cc85879eaefcd577e99e74d07b01566825b3d0461171ef2cbfc7704 llvm-4.0.0.src.tar.xz
-4cb3fabbb627b596ce398ed717c66ad20bbea7092ba30751520cc5a63d38e1ac53d23e98a6ad82121ddcf2434383ba5cadbc2990f99a4528e99c6e2160c2f725 llvm-fix-build-with-musl-libc.patch
-19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
-6d1a716e5aa24e6b9a3acf4cc11e2504b1b01abf574074e9e5617b991de87d5e4e687eb18e85e73d5e632568afe2fc357771c4c96f9e136502071991496fb78c cmake-fix-libLLVM-name.patch
-49c47f125014b60d0ea7870f981a2c1708ad705793f89287ed846ee881a837a4dc0170bf467e03f2ef56177473128945287749ac80dc2d13cfabcf8b929ba58a disable-FileSystemTest.CreateDir-perms-assert.patch
-97f788110abbb9e6add2e3a3d3b606dc2817ab726b74ead71241fc5433ba42d5d58e23be91a3b2444eb687c4f56a7c879bf5453e96f9785ce3541301329dda9c silent-amdgpu-test-failing.patch"