aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-01-28 14:30:29 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-01-30 06:22:45 +0000
commitae88afa1be4209de0638bdd6e50ef6daef7c95b7 (patch)
tree77f78f07767c5af69f5a5764b26f2cd9ec7dcc4a
parent7a2ada76f3edd46a16c049dac49180a5ae309710 (diff)
downloadaports-ae88afa1be4209de0638bdd6e50ef6daef7c95b7.tar.bz2
aports-ae88afa1be4209de0638bdd6e50ef6daef7c95b7.tar.xz
[various]: fix kernel.org 'source' url protocol & hostname
http -> https ftp.kernel.org -> kernel.org
-rw-r--r--main/dtc/APKBUILD2
-rw-r--r--main/hvtools/APKBUILD4
-rw-r--r--main/kmod/APKBUILD2
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-headers/APKBUILD4
-rw-r--r--main/linux-rpi/APKBUILD4
-rw-r--r--main/linux-vanilla/APKBUILD2
-rw-r--r--main/reiserfsprogs/APKBUILD2
-rw-r--r--testing/cpupower/APKBUILD2
-rw-r--r--unmaintained/usbip-utils/APKBUILD4
10 files changed, 15 insertions, 15 deletions
diff --git a/main/dtc/APKBUILD b/main/dtc/APKBUILD
index 4d964b3a6f..43916cfbdd 100644
--- a/main/dtc/APKBUILD
+++ b/main/dtc/APKBUILD
@@ -11,7 +11,7 @@ depends_dev=""
makedepends="$depends_dev bison flex"
install=""
subpackages="$pkgname-dev libfdt"
-source="https://ftp.kernel.org/pub/software/utils/dtc/dtc-$pkgver.tar.xz
+source="https://kernel.org/pub/software/utils/dtc/dtc-$pkgver.tar.xz
use-tx-as-the-type-specifier-instead-of-zx.patch
"
builddir="$srcdir/dtc-$pkgver"
diff --git a/main/hvtools/APKBUILD b/main/hvtools/APKBUILD
index a0382e9f25..8335ff526e 100644
--- a/main/hvtools/APKBUILD
+++ b/main/hvtools/APKBUILD
@@ -10,8 +10,8 @@ license="GPL2"
depends_dev=""
makedepends="$depends_dev linux-headers"
subpackages=""
-source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
- http://ftp.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
+source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
+ https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
hv_kvp_daemon.initd
hv_vss_daemon.initd
hv_fcopy_daemon.initd
diff --git a/main/kmod/APKBUILD b/main/kmod/APKBUILD
index c5f3136136..b2dbe33727 100644
--- a/main/kmod/APKBUILD
+++ b/main/kmod/APKBUILD
@@ -17,7 +17,7 @@ install=""
triggers="$pkgname.trigger=/lib/modules/*"
subpackages="$pkgname-dev $pkgname-doc
$pkgname-bash-completion:bashcomp:noarch"
-source="http://ftp.kernel.org/pub/linux/utils/kernel/kmod/kmod-$pkgver.tar.xz
+source="https://kernel.org/pub/linux/utils/kernel/kmod/kmod-$pkgver.tar.xz
strndupa.patch
kmod-static-nodes.initd
"
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 501d113cb5..0eed78cf3a 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -15,8 +15,8 @@ makedepends="perl sed installkernel bash gmp-dev bc linux-headers mpfr-dev
mpc1-dev"
options="!strip"
install=
-source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
- http://ftp.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
+source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
+ https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
http://dev.alpinelinux.org/~ncopa/grsec/grsecurity-3.1-$pkgver-201604252206-alpine.patch
fix-spi-nor-namespace-clash.patch
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index f833d54efa..17f0a004e8 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -9,8 +9,8 @@ arch="all"
license='GPL2'
makedepends="perl"
options="!strip !tracedeps"
-source="http://www.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
- http://www.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
+source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
+ https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
0001-libc-compat.h-fix-some-issues-arising-from-in6.h.patch
0002-libc-compat.h-prevent-redefinition-of-struct-ethhdr.patch
0003-remove-inclusion-of-sysinfo.h-in-kernel.h.patch
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index a6ed9a43bf..8f3f8d86d8 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -16,8 +16,8 @@ install=
# rpi patches are git diff against latest release tag from:
# linux-4.4.y https://github.com/raspberrypi/linux/tree/rpi-4.4.y
# rpi-cirrus-4.4.y https://github.com/HiassofT/rpi-linux/tree/cirrus-4.4.y
-source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
- http://ftp.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
+source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
+ https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
http://dev.alpinelinux.org/~tteras/rpi/linux-4.4.y-rpi-20161115.patch
http://dev.alpinelinux.org/~tteras/rpi/rpi-cirrus-4.4.y-20160909.patch
gpio-mcp23s08-pullups.patch
diff --git a/main/linux-vanilla/APKBUILD b/main/linux-vanilla/APKBUILD
index ce22e762a7..01f2589dec 100644
--- a/main/linux-vanilla/APKBUILD
+++ b/main/linux-vanilla/APKBUILD
@@ -15,7 +15,7 @@ makedepends="perl sed installkernel bash gmp-dev bc linux-headers"
options="!strip"
_config=${config:-config-vanilla.${CARCH}}
install=
-source="http://ftp.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/linux-$_kernver.tar.xz
+source="https://kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/linux-$_kernver.tar.xz
config-vanilla.aarch64
config-vanilla.armhf
config-vanilla.x86
diff --git a/main/reiserfsprogs/APKBUILD b/main/reiserfsprogs/APKBUILD
index 8b9d65c910..0e0a70250b 100644
--- a/main/reiserfsprogs/APKBUILD
+++ b/main/reiserfsprogs/APKBUILD
@@ -11,7 +11,7 @@ depends=
makedepends="e2fsprogs-dev"
install=
subpackages="$pkgname-doc"
-source="http://ftp.kernel.org/pub/linux/kernel/people/jeffm/reiserfsprogs/v$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://kernel.org/pub/linux/kernel/people/jeffm/reiserfsprogs/v$pkgver/$pkgname-$pkgver.tar.xz"
_builddir="$srcdir"/$pkgname-$pkgver
diff --git a/testing/cpupower/APKBUILD b/testing/cpupower/APKBUILD
index 8ec2f10885..ec6db13946 100644
--- a/testing/cpupower/APKBUILD
+++ b/testing/cpupower/APKBUILD
@@ -14,7 +14,7 @@ depends_dev="pciutils-dev readline-dev"
makedepends="$depends_dev bash linux-headers"
subpackages="$pkgname-doc $pkgname-dev"
replaces="linux-tools-cpupower"
-source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$pkgver.tar.xz
+source="https://kernel.org/pub/linux/kernel/v4.x/linux-$pkgver.tar.xz
cpupower.initd
cpupower.confd
nls.patch
diff --git a/unmaintained/usbip-utils/APKBUILD b/unmaintained/usbip-utils/APKBUILD
index d75c042532..7778885026 100644
--- a/unmaintained/usbip-utils/APKBUILD
+++ b/unmaintained/usbip-utils/APKBUILD
@@ -4,7 +4,7 @@ pkgname=usbip-utils
pkgver=3.14
pkgrel=0
pkgdesc="Utilities for USB device sharing over IP network"
-url="https://www.kernel.org/doc/readme/drivers-staging-usbip-userspace-README"
+url="https://kernel.org/doc/readme/drivers-staging-usbip-userspace-README"
arch="all"
license="GPLv2"
depends="glib sysfsutils usbutils"
@@ -12,7 +12,7 @@ depends_dev="gcc automake autoconf libtool sysfsutils-dev glib-dev"
makedepends="$depends_dev tar"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.gz
+source="https://kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.gz
sigcld.patch
usbip.initd
usbip.confd"