aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-08 21:09:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:47 +0000
commitc032c529bfbdd551f1994133d6e765a5a71cb38c (patch)
tree01451971ef3b633e695e766e6faf28bf6723c3ac
parent9c5236a439a8fe61cd16a6123de7044eed6c71cd (diff)
downloadaports-c032c529bfbdd551f1994133d6e765a5a71cb38c.tar.bz2
aports-c032c529bfbdd551f1994133d6e765a5a71cb38c.tar.xz
testing/asio: rebuild against libressl
-rw-r--r--testing/asio/APKBUILD14
-rw-r--r--testing/asio/libressl.patch27
2 files changed, 36 insertions, 5 deletions
diff --git a/testing/asio/APKBUILD b/testing/asio/APKBUILD
index 4e13fe3357..bf5e8f22c6 100644
--- a/testing/asio/APKBUILD
+++ b/testing/asio/APKBUILD
@@ -2,18 +2,19 @@
pkgname=asio
pkgver=1.10.6
_ver=${pkgver//./-}
-pkgrel=0
+pkgrel=1
pkgdesc="A cross-platform C++ library for network programming"
url="https://think-async.com"
arch="all"
license="Boost"
depends=""
-depends_dev="boost-dev openssl-dev"
+depends_dev="boost-dev libressl-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/asio/asio/${pkgver}%20%28Stable%29/asio-$pkgver.tar.bz2
fix-strerror_r.patch
+ libressl.patch
"
_builddir="$srcdir"/asio-$pkgver
@@ -45,8 +46,11 @@ package() {
}
md5sums="85d014a356a6e004cd30ccd4c9b6a5c2 asio-1.10.6.tar.bz2
-dfc0d5d1c14ca0a247d835c944e400a6 fix-strerror_r.patch"
+dfc0d5d1c14ca0a247d835c944e400a6 fix-strerror_r.patch
+7b3d05cf45e59abc04a61549a401fb82 libressl.patch"
sha256sums="e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e asio-1.10.6.tar.bz2
-0b3eb6d74c9dd11e08368da0f9e09446e2383b5fc840e630581fef3672db95ac fix-strerror_r.patch"
+0b3eb6d74c9dd11e08368da0f9e09446e2383b5fc840e630581fef3672db95ac fix-strerror_r.patch
+6b78adbf094b956e2b3451cfd19a73b1f2c12a9a78a491d64819dd0276239991 libressl.patch"
sha512sums="7146e75a378de57daab88e7ba509ae01367ffa0d7c4c90481e221977a6b9f4fd80e9caac5c6b4c27bc7652e44cd210e2c6cabf5681d7c62747df14bbc25e8c23 asio-1.10.6.tar.bz2
-a023e305a9efa6b93489374dfe9881c447d748a8d48ff803e0ac7ff1be618460b57de024e79da8c08dab4bcd214cbf2c3991d963eef678ca8dbd48b3c8933a70 fix-strerror_r.patch"
+a023e305a9efa6b93489374dfe9881c447d748a8d48ff803e0ac7ff1be618460b57de024e79da8c08dab4bcd214cbf2c3991d963eef678ca8dbd48b3c8933a70 fix-strerror_r.patch
+6caeb4748f1a68783e2da3f548f3a4f91e413d96ba3a508b8279f04a1fd1f73f8d5d53f1b2bb1accf2a15bd3056144fce64668bf06091550055d125aef2169b7 libressl.patch"
diff --git a/testing/asio/libressl.patch b/testing/asio/libressl.patch
new file mode 100644
index 0000000000..c62f5230ad
--- /dev/null
+++ b/testing/asio/libressl.patch
@@ -0,0 +1,27 @@
+diff --git a/include/asio/ssl/impl/context.ipp b/include/asio/ssl/impl/context.ipp
+index 4a66a0a..dfa6cee 100644
+--- a/include/asio/ssl/impl/context.ipp
++++ b/include/asio/ssl/impl/context.ipp
+@@ -88,6 +88,14 @@ context::context(context::method m)
+ handle_ = ::SSL_CTX_new(::SSLv2_server_method());
+ break;
+ #endif // defined(OPENSSL_NO_SSL2)
++#if defined(OPENSSL_NO_SSL3)
++ case context::sslv3:
++ case context::sslv3_client:
++ case context::sslv3_server:
++ asio::detail::throw_error(
++ asio::error::invalid_argument, "context");
++ break;
++#else
+ case context::sslv3:
+ handle_ = ::SSL_CTX_new(::SSLv3_method());
+ break;
+@@ -97,6 +105,7 @@ context::context(context::method m)
+ case context::sslv3_server:
+ handle_ = ::SSL_CTX_new(::SSLv3_server_method());
+ break;
++#endif
+ case context::tlsv1:
+ handle_ = ::SSL_CTX_new(::TLSv1_method());
+ break;